Exception: ddo_set_param: error setting DDO parameter.

When running EmbeddedKitService.py from the Developer’s Kit,
I am getting the following output:

#> py EmbeddedKitService.py

Starting up…
Ready for incoming requests!
Discovering nodes…
00:[00:13:a2:00:40:52:46:8c]!-X2#1
00:[00:13:a2:00:40:54:8a:54]!- CC
00:[00:13:a2:00:40:4b:95:df]!- AA
00:[00:13:a2:00:40:53:64:e0]!- BB
00:[00:13:a2:00:40:53:6e:1c]!- USB-S1Pro

Note: for 802.15.4 modules, some application functionality will be limited.
Specifically, voltage readings are not available and LEDs 1 & 2 on the dev
boards will always be illuminated regardless of application state.

[00:13:a2:00:40:54:8a:54]!
17
3
Traceback (most recent call last):
File “WEB/python/EmbeddedKitManager.py”, line 286, in _set_dio_status
return_value = ZtsWPANManagement.set_dio_status(addr_extended, pin_number, s
tatus)
File “WEB/python/embedded_kit_gateway.zip/Zts/WPANManagement.py”, line 40, in
set_dio_status
File “WEB/python/embedded_kit_gateway.zip/Zts/Digi/WPANManagement.py”, line 11
6, in set_dio_status
Exception: ddo_set_param: error setting DDO parameter.
----- End of Python Output ----

I upgraded the XBee Modules on the RS232 and USB Interface Boards to 0x10CD firmware.

Here is my network (Standard Dev Kit Contents)

---- Beginning of Network List ----
Node ID Extended Address Product XBee Module Firmware
X2#1 00:13:a2:00:40:52:46:8c! ConnectPort X2 XBP24-AUI-001? 0x10c8
CC 00:13:a2:00:40:54:8a:54! XBIB-R-DEV XB24-AWI-001 0x10cd
AA 00:13:a2:00:40:4b:95:df! XBIB-U-DEV XBP24-AUI-001 0x10cd
BB 00:13:a2:00:40:53:64:e0! XBIB-R-DEV XBP24-ACI-001 0x10cd
USB-S1Pro 00:13:a2:00:40:53:6e:1c! XBee USB Adapter XBP24-A?I-001 0x10c8
---- End Of Network List ----

Has anybody seen this behavior?
What is a DDO parameter?

Thanks

hi,

its a normal error while reading/writing to nodes.
checklist is simple:

  • node is offline (restart, recheck nodes)
  • command does not support your parameter: zigbee.ddo_set_param(DEST, ‘D0’, 8) [values 0…5]
  • command does not have parameters: zigbee.ddo_set_param(DEST, ‘WR’)
  • multiple connections to single node (restart, recheck gateway)

Simon

Before running the program make sure that the nodes are in the same network.