Hello World Timeout in Remote Console

I’m just getting started with Digi ESP and Linux. I’ve managed to build and launch the simple hello world application which prints hello world to the terminal 10 times, HOWEVER, after 5 seconds the Remote Console Tab says ‘Disconnected@192.168.0.112[hello_world_c]hello_world_c’ and stops. What happened? I’m looking for a timeout setting somewhere but can’t seem to find it help!

I tried the gpio sample with the same result - it seems that the application stops on the target - disconnected at the target?

Thanks!

its because your main() is returning to kernel.

relpace “return;” with " while(1); "
you can find the difference

That makes sense, but alas, same result. My code is below. Is there a configuration file somewhere on the target that needs to be modified?

Thanks for your help!

/*

  • hello_world.c
  • Copyright (C) 2009 by Digi International Inc.
  • All rights reserved.
  • This program is free software; you can redistribute it and/or modify it
  • under the terms of the GNU General Public License version 2 as published by
  • the Free Software Foundation.
  • Description: Hello World test application

*/
#include
#include

int main(void)
{
int cnt;

for (cnt = 0; cnt < 18; cnt++) {
	printf("%d Hello World!

", cnt);
sleep(1);
}
printf(“here”);

while(1);

}

ahh… thats weird.
for me it remain “connected” …

btw which hardware are you using?
and whats your Digi ESP version?

try to initiate a telnet connection to the target.
what is happenig when you say “RUN” is ::

It is transfering the application binary via FTP to the module, than launches a telnet session to start it.