How to test apps through TCP

Can I upload my test application - without debug info - through FTP and run the application?

It takes for ages to run through the JTAG



Regarding the speed when downloading an application through gdb, have you made certain that your parallel port is set for EPP mode?

While both ECP and EPP will work, EPP tends to perform better. I have experienced, first hand, that many laptops do not provide EPP support, so downloading can be painfully slow (50kbps vs. 250kbps).

As to your initial question, sure you could load the ftp server application, upload your binary image and test. Just make certain that you include the ftp server code with your application and start the server close to the beginning of your applicationStart() function. I see real problem with this other than your application could possible perform some action that would be cause for you to have to reboot the device or depending on what the application does could cause you to have reload the image via the debugger again.

Perhaps some more seasoned developers could offer their input as well.



What I mean to say is that with the FTP server included in your application uploading a new version of your application will be easier, as you would not have to load the FTP server through the debugger and push your image up each time you make a change.


Just a note. That is what you have to do for your final version anyway. Check out some of the older threads on “without a JTAG”.


I think my connection is using ECP, so maybe that my problem.

I am working from a normal PC; but would very much like to use my Thinkpad instead. I will check the parallel port mode later.

So that means if I don’t include the FTP server code, I have to reboote my board after each test.


Ok I get it, so my application is able to receive an “update” - quite clever


Hi All,

Well got carried away, compiled “template” -> “hello world”

  1. Uploaded “image.bin” 230kb with 8k a sec?

  2. Nothing happened.

  3. Rebooted board

  4. Yes -> “Hello World”

But how do I upload another image now?

Tried gdbtk with JTAG, but board just reboots after a while after Control -> Continue

I though that the file was uploaded to RAM and not FLASH (probally why 8kb a sec)

How do I fix this?

And yes stupid me!

After it is loaded into the RAM, it needs to be copied to the FLASH. Normally if you are using FTP or the command line one time uploader this is taken care of for you. If you are using the JTAG it should operate out of RAM after your download with the Raven, but it is NOT saved when you use the Raven/gdb, so a reboot will wipe it out.

If you want the program in the FLASH and you have a JTAG connector, compile and run the FTP example, then FTP in the image.bin from the program you want. It will automatically program the FLASH after uploading.



Got naftpapp up and running with gdb :slight_smile:

Is “Transfer rate: 373609 bits/sec, 511 bytes/write.” is this a good speed for the JTAG?

I then uploaded the “image.bin”, but when I reboot board either with reset button or power off/on, nothing happens.

The application don’t seem to run. The NetSilicon text only appears when I use gdb and do “cont”

Just currious : “Press any key in 5 seconds to change these settings.” is that the firmware or?


Got it up and running again :slight_smile:

Is it normal that the board is over 30secs to start?


You FTPed the image.bin after the gdb image was running on the JTAG, right? If you have the image.elf for the FTP program on gdb, try FTPing the image.bin for naftpapp since you KNOW that it works, then reboot. If it still doesn’t come up, let me know. If it does, then some of your program settings are off and we can figure them out.

BTW: if you are running with gdb, it is operating off the RAM on the ConnectME so there is almost no speed difference between standalone and gdb operation. gdb just handles the breakpoints which are intrinsic to the processor.

If you have the startup “dialog”/splash turned on - yes, 30sec is normal.


(just another user)