Integration app only works on certain versions of browsers

Is there any reason the integration application only works on specific versions of FireFox, Safari, (Cannot ever get it to work with IE Explorer).???

Is there a list of specific browsers and versions I can use??

Unfortunately IE 8.0 has un-predictable issues.

Even at Digi, certain people have trouble with IE8 and others never have trouble. I know Digi had someone spend quite a bit of time on this problem, but could never detect the exact cause of the problem, so there was never anything to fix.

It is some kind of JavaScript issue.