Can't get to start

I downloaded your 2.4.3 version of python and if I run python -V that is what it reports.
bash-3.2# python -V
Python 2.4.3
bash-3.2# python demos/green_getting_started/green_getting_started.yml
Project make started.
Analyzing files…
Compiling files…
Zipping files…
Finished writing archive ‘/Users/rich/Downloads/dia_pkg_1.3.8/bin/’
Transforming settings file ‘demos/green_getting_started/green_getting_started.yml’ to ‘pyr’ format…
Adding transformed settings as ‘dia.pyr’ to ‘/Users/rich/Downloads/dia_pkg_1.3.8/bin/’…

But all attempt to run in from the telnet lose with
#> python green_getting_started.yml

Determining platform type…Digi Python environment found.

Error: unable to load required library!
Check to make sure that ‘WEB/python/’ is not corrupt.
Also verify that it was compiled against Python 2.4.3

Startup halted.

I read the source and it is failing on the load of zipfile that is in the, I verified that. So I have no clue where to go next.

I ran into the same issue and ultimately a reboot of the X4 gateway
( I used the reset/reboot command from the telnet interface ) caused the software to start working.

I tried the reboot several time before posting. Any other suggestions?

Once you have compiled the .yml file on your computer you must open the web interface of the X4 gateway, select python and upload the files idigi_dia\bin\, and the file idigi_dia\ Once these files are on the X4 then you telnet to the X4 at the prompt type python