ConnectCore 6UL Express OS/firmware upgrade/installation failed!


I tried to update the OS/firmware of my “ConnectCore 6UL SBC Express” to DEY v3. I followed the normal method of micro SD card as I did to DEY v2.4 and v2.6. However, the process failed. It seemed that the u-boot loader was corrupted. So I tried to recover the u-boot loader with the Linux UUU method and it was successful.

Then, I continued to update from scratch to install DEY v3. I booted my “ConnectCore 6UL SBC Express” to “Recovery Mode” and tried to install from micro SD card. However, the command did not respond at all. It simply showed once more:
=> run install_linux_fw_sd
=> run install_linux_fw_sd

Then, I tried the USB storage method by running:
=> run install_linux_fw_usb

It showed that these files were not found! Actually, they were saved in the USB drive!

I then tried this command:
update uboot mmc 0 fat u-boot-ccimx6ulstarter.imx

It reported that it could be saved to RAM.

So, how do I correct this and install DEY v3? Is my board dead already?

Thanks for any opinion.

1 Like

try formating your SD card again and make surethe filesystem you select is FAT
what error are you getting after:
update uboot mmc 0 fat u-boot-ccimx6ulstarter.imx
Please provide the output of the following commands
env default –a
mmc list
mmc info
mmc dev 0
mmc part
ls mmc 0

Hello Leon,
Here are the output. It seems that the board is faulty.

Hit any key to stop autoboot: 0
=> run install_linux_fw_sd
=> update uboot mmc 0 fat u-boot-ccimx6ulstarter.imx
Error loading firmware file to RAM
=> env default -a
*** Warning - ## Resetting to default environment
, using default environment

Error: Can’t overwrite “ethaddr”

himport_r: can’t insert “ethaddr=00:04:f3:ff:ff:fa” into hash table

Error: Can’t overwrite “btaddr”

himport_r: can’t insert “btaddr=00:04:f3:ff:ff:fc” into hash table

Error: Can’t overwrite “eth1addr”

himport_r: can’t insert “eth1addr=00:04:f3:ff:ff:fd” into hash table
=> saveenv
Saving Environment to NAND… Erasing redundant NAND…
Erasing at 0x320000 – 100% complete.
Writing to redundant NAND… OK
=> reset
resetting …

U-Boot dub-2020.04-r2.2+ge135e76d14 (Jan 21 2021 - 22:46:12 +0000)

CPU: i.MX6UL rev1.1 528 MHz (running at 396 MHz)
CPU: Industrial temperature grade (-40C to 105C) at 49C
Reset cause: POR
I2C: ready
DRAM: 256 MiB
PMIC: PFUZE3000 DEV_ID=0x30 REV_ID=0x11
NAND: 256 MiB
In: serial
Out: serial
Err: serial
Model: Digi International ConnectCore 6UL Starter Board.
ConnectCore 6UL SOM variant 0x02: Industrial Ultralite 528MHz, 256MB NAND, 256MB DDR3, -40/+85C, Wireless, Bluetooth
Board version 2, ID 129
Boot device: NAND
WARNING: Dummy default MAC in ‘wlanaddr’
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 0
ubi0: attaching mtd4
ubi0: scanning is finished
ubi0: empty MTD device detected
ubi0: attached mtd4 (name “linux”, size 12 MiB)
ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
ubi0: good PEBs: 96, bad PEBs: 0, corrupted PEBs: 0
ubi0: user volume: 0, internal volumes: 1, max. volumes count: 128
ubi0: max/mean erase counter: 0/0, WL threshold: 4096, image sequence number: 0
ubi0: available PEBs: 88, total reserved PEBs: 8, PEBs reserved for bad PEB handling: 4
UBIFS error (pid: 1): cannot open “ubi0:linux”, error -19
Error reading superblock on volume ‘ubi0:linux’ errno=-19!
ubifsmount - mount UBIFS volume

- mount ‘volume-name’ volume
=> mmc list
=> mmc info
MMC Device 0 not found
no mmc device at slot 0
=> mmc dev 0
MMC Device 0 not found
no mmc device at slot 0
=> mmc part
MMC Device 0 not found
no mmc device at slot 0
=> ls mmc 0

your board does not see your SD card, it’s either not inserted properly or bad SD card or something is wrong with the SD card slot on the board. The expected result should be:
=> mmc dev 0
switch to partitions #0, OK
mmc0 is current device
=> mmc info
Device: FSL_SDHC
Manufacturer ID: 3
OEM: 5344
Name: SE32G
Bus Speed: 50000000
Mode: SD High Speed (50MHz)
Rd Block Len: 512
SD version 3.0
High Capacity: Yes
Capacity: 29.7 GiB
Bus Width: 4-bit
Erase Group Size: 512 Bytes
=> mmc part

Partition Map for MMC device 0 – Partition Type: DOS

Part Start Sector Num Sectors UUID Type
1 8192 62325760 bba149b1-01 0c

=> ls mmc 0
System Volume Information/
592896 u-boot-mfg.imx
8634368 dey-image-qt-x11-ccimx6ulsbc.boot.ubifs
13078528 dey-image-qt-x11-ccimx6ulsbc.recovery.ubifs
112119808 dey-image-qt-x11-ccimx6ulsbc.ubifs
2459 install_linux_fw_ram.scr
728064 u-boot-ccimx6ulsbc.imx
715776 u-boot-ccimx6ulstarter-2020.04-r0.imx
723968 u-boot-ccimx6ulstarter-2017.03-r0.imx

8 file(s), 14 dir(s)


This is a known issue with u-boot for cc6ul starter board on dey-3.0r3. We are in the process of releasing de-3.0r4 where it is fixed. It might have already pushed to git , so if you update your Yocto

~$ repo init -u -b zeus
~$ repo sync -j8 --no-repo-verify

you should get the latest version of u-boot with fix.