Digi Connect Port RX pins not working correctly

I have a connect port TS8, I have set the device up with industrial automation routing modbus TCP on port 502 to modbus RTU out serial port number 1 as RS232 96008N1.

When I test the device with MDBUS running as as master (using Ethernet port on PC) and as a slave on the PC (using COM1 serial port) the device successfully sends TCP packets and then receives the data back.

When I use the device with various PLCs in exactly the same setup (PC as master, PLC as slave) the PLC receives the request and responds (can be verified by snooping the TX pin from the PLC) with the correct response, the DIGI RX light however does not light up and no response is sent back to the PC modbus master.

I have tried 4 different PLCs with various different settings, only MDBUS on the PC seems to work. Snooping the TX pin from the PLC back to the RX pin on the DIGI reveals the correct data is on this pin, the DIGI however refuses to acknowledge it.

I am connecting the PLC TX pin to the DIGI RX pin 6 via RJ50 plug, this is pin 5 and blue/white if using an RJ45 cable. I am confident this is not a wiring problem as it works correctly when connected to a PC’s serial port. The PLC operates a similar TTL voltage for rs232 as the PC

I have tried multiple ports on the device with different baud rates with the same result. What is the next step?

I recommend running a loopback test on the port to ensure the integrity of the port: