Digi Portserver 16

i’m having problem installing/configuring a printer in one of the ports of 16. i can telnet the digi portserver 16 device. the printer is connected via an RJ45 from the device to printer’s serial port (DB25?). my OS’ IBM AIX 5.3.

-> print spolling
-> aix print spooling
-> add a print queue
-> hpJetDirect Network Printer (HP JetDirect) -> Other
-> generic (Generic Printer)

  • #2 Do not make this system a BOOTP/TFTP Server
  • ASCII, hostname of the JetDirect Card and Port (9100) are provided.

any idea/s what needs to be checked or changed?


below are some of the info re current digi-ps 16 settings:

#> set ports range=1-16
tty termtype dev sess uid edelay auto bin group dport dest
1 wyse50 prn 4 0 1 on on 0 9100
2 wyse50 term 4 0 1 on off 0 0
16 wyse50 term 4 0 1 on off 0 0

You will want to install the RealPort driver on the AIX host:

For AIX version 5.x:


Here are the instructions for installing the driver:


Installing/configuring printers in smit:



thank you for the resources, i got it (driver) installed on AIX 5.3 server. under devices - it is now showing “Digi Device and Terminal Servers”

Digi Device or Terminal Server sa2
Description Digi PortServer 16
IP Address []
STATUS of Device at Config Time up
Server Port Number [771]
WAN Link Speed []
Encrypt RealPort session never
Encrypt Server Port Number [1027]

Under my portserver config:

#> set config
PortServer Version 3.4.4 December 18, 1995
Copyright 1990-1995 DigiBoard. All Rights Reserved.
myname : PORTSERVER domain : mydomain.box.com
ip : submask :
gateway : nameserv :
ether : xx:xx:xx:xx:xx:xx
boothost : bootfile :
realport : 771

#> set flow range=1-2
tty ixon aixon ixoff ixany itoss altpin rts dtr cts dcd dsr ri
1 off off off off off on off off on off off off
2 off off off off off on on off on off off off
16 on off off off off on off off off off off off

#> set ports range=1-2
tty termtype dev sess uid edelay auto bin group dport dest
1 wyse50 prn 4 0 1 on on 0 1
1 wyse50 prn 4 0 1 on off 0 1

NOTE: i trying to use port#2, as setting it up to port#1 - the system’s using it for sa1 (tty2). this is confusing. it looks like the system used port#1 for the entire portserver 16 device and you can only use RJ45 port#2 on the box.

the tty settings:

TTY tty2
TTY type tty
TTY interface rs232
Description Asynchronous Terminal
Status Available
Location 00-00-02-01
Parent adapter sa2
PORT number [1]
Enable LOGIN disable
BAUD rate [9600]
PARITY [none]
BITS per character [8]
Number of STOP BITS [1]
TIME before advancing to next port setting
TERMINAL type [dumb]
FLOW CONTROL to be used [xon]
OPEN DISCIPLINE to be used [dtropen]
STTY attributes for RUN time [hupcl,cread,brkint,ic
STTY attributes for LOGIN [hupcl,cread,echoe,cs8]
LOGGER name []
STATUS of device at BOOT time [available]
STREAMS modules to be pushed at OPEN time [ldterm] Force Carrier disable
INPUT map file [none]
OUTPUT map file [none]

root pts/11 $ lpstat
Queue Dev Status Job Files User PP % Blks Cp Rnk

testpr lp0 DEV_WAIT 53 STDIN.25054 root 4 1 1

would the problem be related to the RJ45 to DB25 (IBM Code 1P61120024D/0117 CoO:CN) connection? what would be the termination/connection of RJ45/DB25 for this settings?

Try asserting DCD on the device in the event you are using an 8-wire cable:

chdev -l tty2 -a forcedcd=enable

If you still experience problems, the cable pin-out can be confirmed here:


The naming convention is native to AIX. I thought I had a procedure that could allow you to change the tty names, but I cannot seem to locate it at the moment. If you are sincerely interested in doing this, I’ll try and dig deeper. Although, it should be mentioned that this not something officially supported (disclaimer).

Hope this helps.

hi userid0 -

i think i have no choice but to really work on this to work, very interested. i tested the one the you provided here and even check the cable connection of rj45-to-db25.
i still got the DEV_WAIT status everytime i sent print job.

here’s what my understanding right now in terms of AIX ports (as I configured it):

tty0 = port # 0 of sa0 (serial #1)
tty1 = port # 0 of sa1 (serial #2)
tty2 = port # 1 of sa2 PortServer 16 (0=NOT option, error)
tty3 = port # 2 of sa2 PortServer 16
tty4 = port # 3 of sa2 PortServer 16
tty5 = port # 4 of sa2 PortServer 16

tty2 -> i deleted and created it as a printer, with queue name “testpr” using lp0 (a direct local printer) from
[Is #9 -> TTY=lp0???]

cat inittab | lp -dtestpr (shows)

testpr lp0 DEV_WAIT 55 STDIN.14146 root 4 1 1

Typically the “DEV_WAIT” error indicates the spooler is waiting for carrier assertion (DCD).

Are you able to cat data directly to the port (bypassing the spooler)?

cat /etc/inittab > /dev/lp0

If so, then you will want to be sure and apply the following setting on the lp device:

chdev -l lp0 -a forcedcd=enable

If the cat command does not work, try bypassing the driver and use telnet:

cat /etc/inittab | telnet (IP_of_unit) 2001

i tried this before attempting to force print:

root pts/2 $ chdev -l lp0 -a forcedcd=enable
lp0 changed

nothing happens here (is 2002 a default port for port #2?):

root pts/2 $ cat /etc/inittab | telnet 2002
Connected to
Escape character is ‘^]’.
Connection closed.
root pts/2 $

this one just hanged up - no result:
root pts/2 $ cat inittab > /dev/lp0

#> set ports range=1-16
tty termtype dev sess uid edelay auto bin group dport dest
1 wyse50 prn 4 0 1 on on 0 1
2 wyse50 prn 4 0 1 on off 0 2
16 wys50 prn 4 0 1 on off 0 0

i’m wondering about the “dport”, should you need to change it to match whatever is on the native AIX system, i.e., options are from 1 to 16?

You will want to turn off the “auto” setting on these ports. When using RealPort, the only values that should be changed on the PortServer are the “dev” and possibly the “altpin” setting. All other settings should remain at the default values, as they are now controlled by the RealPort host (AIX).

To turn off the auto flag:

#> set port auto=off range=(port#)

Also, the bin flag:

#> set port bin=off range=(port#)

Might be a good idea to reboot after changing this:

#> boot action=reset

You may want to double check the printer cable pin-outs, as it seems the telnet method was successful. Unfortunately, I am not able to cross-reference the IBM part number.

after tryng what you mentioned here…looks like things changed. when i tried below command, the physical printer made a sound and i have to turn it off (but looks like its communicating now but NOT what we all expected :)).

root pts/1 $ cat /etc/inittab | telnet 2002
Connected to
Escape character is ‘^]’.
Connection closed.

but when i tried this one, still the same - it hanged.

root pts/1 $ cat inittab > /dev/lp0

it makes me think it’s not really supported in AIX 5.3 (this portserver 16).

something/s happened (improvement if i’m correct). i re-booted all the systems and now what happened to my print jobs - was, it vanished from the queues but NOT printed.

cat /etc/inittab | telnet 2002

  • this one make noise - a non-stop beeping sound on the printer

cat /etc/inittab | lp -dtestpr

  • print job’s gone and NOT printed

cat /etc/inittab > /dev/lp0

  • print job’s gone and NOT printed

thank you userid0. i really appreciate your input.

whew! finally, after so many attempts to make it work - we decided to buy “jetdirect” card and put-to-shelf this portserver 16.

anybody with same problem as i have now?

i re-started doing test on this… this still interests me.

improvements are the following:

1.) i can now print but “garbled”(unreadable, special characters) output using

root pts/1$ cat /etc/inittab >/dev/lp1

  • properties shows
    name: lp1
    type: osp
    interface type: rs232
    description: other serial printer
    status: available
    location: 00-00-02-10
    parent: sa2
    connection address: 10

PORT number [10]
BAUD rate [9600]
PARITY [none] +
BITS per character [8] +
Number of STOP BITS [1] +
FLOW CONTROL to be used [xon] +
OPEN DISCIPLINE to be used [dtropen] +
STTY attributes for RUN time[clocal] +
STREAMS modules to be pushed at OPEN time [sptr] Printer TIME OUT period [60] +
STATUS of device at BOOT time available +
Ignore the following attributes when using the Print Queue:

Number of LINES per page [66]
Number of COLUMNS per page [80]
Number of COLUMNS to indent [0]
Send all characters to printer UNMODIFIED yes
WRAP CHARACTERS beyond the specified width no
Convert lowercase to uppercase no
Expand TABS on eight position boundaries yes
Return on ERROR no

2.) i can now print but “garbled” output using

root pts/1$ cat /etc/inittab | lp -dtestpr

Print queue name testpr
Printer name lp1

FORMATTING FLAGS for header page []
FORMATTING FLAGS for trailer page []
USERS to get intervention messages []
FLAGS PROHIBITED for ASCII print files []
FLAGS PROHIBITED for all print files []
ALIGN page if printer is idle no +
Number of FORM FEEDS when printer goes idle [never]
WIDTH of printable area on header page [77] +#

                Change / Show Default Print Job Attributes

Type or select values in entry fields.
Press Enter AFTER making all desired changes.

                                                    [Entry Fields]

Print queue name oki1
Printer name lp1

-------------- Text Print Options -------------

----------- Job Processing Options ------------
PAGE NUMBER where printing should begin [1] +#
Print file TYPE a +
Pre-processing FILTER NAME [p] +
INITIALIZE printer? yes +
RESTORE printer? yes +

----------- Text Formatting Options -----------
TOP MARGIN (lines) [0] +#
BOTTOM MARGIN (lines) [0] +#
Number of columns to INDENT [0] +#
WRAP long lines? yes +
CODE PAGE of print file [ISO8859-1] +
CODE PAGE of printer ascii +
Send FORM FEED after each file? yes +
TITLE STRING for ‘pr’ filter []
LINES per page [66] +#
COLUMNS per page [80] +#
LINE DENSITY (lines per inch) 6 +

------------- Paper/Page Options --------------

--------- Header/Trailer Page Options ---------

------------- Messages/Diagnostics ------------
DIAGNOSTIC LEVEL (normal) - print job; exit> +

Garbage data is almost always an indication of a setting mis-match (baud, partity, stop bits, character bits, flow control, etc…).

You will want to look at the settings on the attached printer to confirm they match those applied on the lp device in smit.

Have you tried connecting the printer to a built in AIX serial port (tty0, tty1)? Since, the RealPort driver is designed to emulate the built in serial ports as closely as possible, it would would be interesting to know if the printer works on any serial port.