Error installing Digi Embedded Yocto

Hi everybody,
I am new using Digi devices. I am trying to install Digi Embedded Yocto by following the steps in
but when I do “repo init -u -b refs/tags/1.6.5” I have the following error:
Traceback (most recent call last):
File “/usr/local/dey-1.6/.repo/repo/”, line 506, in
File “/usr/local/dey-1.6/.repo/repo/”, line 482, in _Main
result = repo._Run(argv) or 0
File “/usr/local/dey-1.6/.repo/repo/”, line 161, in _Run
result = cmd.Execute(copts, cargs)
File “/usr/local/dey-1.6/.repo/repo/subcmds/”, line 390, in Execute
File “/usr/local/dey-1.6/.repo/repo/subcmds/”, line 176, in _SyncManifest
r = m.GetRemote(
File “/usr/local/dey-1.6/.repo/repo/”, line 679, in GetRemote
return self.config.GetRemote(name)
File “/usr/local/dey-1.6/.repo/repo/”, line 188, in GetRemote
r = Remote(self, name)
File “/usr/local/dey-1.6/.repo/repo/”, line 532, in init = self._Get(‘review’)
File “/usr/local/dey-1.6/.repo/repo/”, line 668, in _Get
return self._config.GetString(key, all_keys = all_keys)
File “/usr/local/dey-1.6/.repo/repo/”, line 132, in GetString
return self.defaults.GetString(name, all_keys = all_keys)
File “/usr/local/dey-1.6/.repo/repo/”, line 129, in GetString
v = self._cache[_key(name)]
File “/usr/local/dey-1.6/.repo/repo/”, line 246, in _cache
self._cache_dict = self._Read()
File “/usr/local/dey-1.6/.repo/repo/”, line 253, in _Read
File “/usr/local/dey-1.6/.repo/repo/”, line 283, in _SaveJson
if os.path.exists(self.json):
AttributeError: ‘GitConfig’ object has no attribute 'json

Can somebody help me please?
Thanks :slight_smile:

looks like this is reported here with workaround:
or delete .repo folder and try again

I deleted it and tried again but it didn’t work.
I just forgot to register in git actually. After doing "sudo git config --global “your@email” it worked.

The updated Digi Embedded Yocto guide is now available at this URL: