fat_AutoMount Running out of XMem


When this line is executed, Dynamic C shows me a dialog window saying “Run Time Error : Xmem allocation failed (out of memory)… Address 4c:879e”, and the program resets.

Here’s a printout of xalloc_stats(xubreak) run immediately before automount:

Available xalloc() regions:

Low addr High addr Current Avail Type

  FEF0        FFDE        FFDE          EE  normal                          
 13086       13BFE       13BFE         B78  normal                          
 5AA68       5E000       5E000        3598  normal                          
 60010       7B000       7B000       1AFF0  normal                          
100010      101168      101168        1158  BB RAM                          
10D010      17879E      17879E       6B78E  BB RAM 

Which shows more than 500kBytes of available Xmem.

When I run AutoMount with FDDF_NO_RECOVERY, Automount fails out with -22 which is EINVAL. The manual says that this means “invalid prtTable” but this word appears nowhere else in Dynamic C documentation and I have no idea what it means.

I have tried reformatting the SD card; it has not helped.

Please help!