Forcing sleep mode when out of range

Ok, where is the problem if the coordinator stay always on, and the end device stay on only when it has to send data?

My coordinator stay always on, the problem is the end devices module it doesn’t wake up when the coordinator perform the ATND command (discover nodes) and if I do the communication as I commented to you above I’m pretty sure that I would lost important data.

The coordinator (PC) perform the ATND command every 30 sec.
The end device (microcontroller) it’s wake up every 30 sec and then goes to sleep for about 3 min.

Some time ago I made ​​a test, the two modules were set to work in transparent mode.

During normal operation, turn off the end device. After a while, turn it on, and immediately was connected to the coordinator sending data.

You might try it too?

I have all my XBees working in transparent mode (the API mode is to complex and what I need it’s simplicity). That’s the problem [During normal operation, turn off the end device. After a while, turn it on, and immediately was connected to the coordinator sending data.] I have 3 end devices and 1 coordinator, when 1 of the end devices wake up form sleep and send data the coordinator this one receives all fine but if another end device wake up from sleep and send data meanwhile the first en device is sending data the coordinator this one receives ALL data (end device 1 and end device 2) and I can’t identify where the data come from.
End device 1 has to send 00 99 88 77 66 55
End device 2 has to send 22 12 05 43 21 99

End device 1 wake up and start send 00 99 88 and just at that moment the End device 2 also wake up and start to send data.

The XBee never lost packets and always receive all, the coordinator would receive 00 99 88 22 77 12 66 05 55 43 21 99.

Finally the problem is I can’t make that the coordinator just listen only one of the end devices, is always keep listening all the messages sent to it.

Thank you.

And if you include at every message a code that identify uniquely only one xbee?

For example

01 00… first module
02 33… second module
03 88… third module
02 56… second module

The solution it’s good enough for me, I did not think that, it’s a lot of work from PC side but worth it!.

Thank you a lot my friend.

An interesting thread… It has always amazed me that for a platform designed for very low power consumption (i.e. years not hours), that the XBee has no built in support for regulating power consumption when the coordinator/routers are unreachable. This is not simply an issue of devices roaming, but could be the result of a power outage or plug pack being bumped off the wall etc.

Anyway, as it hasn’t been mentioned yet… consider limiting the channel set to only 1 (or a few) channels. Each time the XBee is woken up, the scan iterates across all configured channels (thus taking several time longer).

I would prefer to take note of OI parameter for the moving series 2 XBee Coordinator. And Set II to previously noted OI value. And then Restart the coordinator. Also keep the SC, ID same as default.