How to install ssl certificates automatically?

Hi

I’m running HTTPS Server Example using the AWS, I know how to install the 2 required certificates manually.
"
How to add certificates to Internet Explorer data base?

  1. Using IE Tools menu goto Internet Options…
  2. Select Content window
  3. Click certificates… button
  4. Add CA certificate to database
    a. Select Trusted Root Certificate Authorities
    b. Click on import
    c. Use wizard to browse ./keys/cacert.pem and complete the wizard
    d. This will add NASSL CA to the Trusted Root CA list
  5. Add client certificate
    a. Select Personal from the certificate window
    b. Click on import
    c. Use wizard to browse httpsClnt.pfx
    d. Enter ‘Digi https key’ as password and complete the wizard
    e. This will add Nassl Client to the Personal list
  6. If you want to add revoked client then follow step 5, but browse for
    httpsRevClnt.pfx and ‘Digi https rev key’ as password
    "

But my question is: Is there a way to install the 2 SSL certicates required for this example automatically when an user connect (connect by typing https://ip_address)?

Hello

We did a some research on loading certificates into browsers. There are NO automated methods for loading certificates into browsers.

You might keep an eye on the MS internet explorer web site to see whether, at some point Microsoft adds such a capability. At this juncture, though, we are unaware of any efforts by Microsoft to do so.

Hi,
We are using NETOS6.1 for NS9750 silicon.

We have implemented Advaced Web-server using NET+OS6.1 GHS and made to run on our product successfully from past few years. Now we are implementing Advaced Web-server HTTP over SSL (that is HTTPS). For this, we have tried compiling crypto.a, libcrypto.a and ssl.a along with the present project .bld file.

But we ended up with an error as “unresolved symbols from ssl.a and libcrypto.a” shown in the below attached screen shots.

I have reffered all threads in this forum, but didnt get a solution to overcome this problem. And also my main concern is Digi is not providing any sort of support for NETOS6.1 GHS.

But in the below attached thread “http://www.digi.com/support/forum/viewthread_thread,2314_offset,10#7633” “egwarty”
mentioned that he has placed some header files in the link with which it compiles succesfully; but didnt find any as such.

Please let me know the solution to overcome this problem.
Any Reply is most appreciated to all.

Thanks,
KRAVIK

Please find the screenshot below with linker error thrown while building libcypto.a, ssl.a library files.

Hoping a reply.

Thanks,
KRAVIK

Please find the screenshot below with linker error thrown while building libcypto.a, ssl.a library files.

Hoping a reply.

Thanks,
KRAVIK

Please find the screenshot below with linker error thrown while building libcypto.a, ssl.a library files.

Hoping a reply.

Thanks,
KRAVIK