I cannot receive data packet by using XBee pro S3B.

I am using XBee pro S3B with adapter for wireless communication. It worked fine before, however, suddenly I am not able to communicate each other. I usually send and receive data packet by python or C++. But now, I am mostly checking console supported by XCTU.

I am using adapter made from Waveshare and the reason why I think the problem is receiver is because The TXD led on the adapter blinks when I transmit data packet to the xbee. However, I cannot see RXD led blinking to the other side. This did not happened before, so it is really difficult to figure out the reason for this issue.

Now let me describe what I did. Currently I have 4 device with me and I tried all the possible combination to communicate with them. Before sending the data packet, I changed the destination mac address to what it should be. Then I double checked whether it is in AT mode and then I went to console working mode. If the device is ‘paired’ (or they are working fine) I should see something written from another side also. However, it never happened. Then I used python script with pyserial, however, It never seems receiving something from other side. Again, TXD is blinking, RXD is not.

After that I even re-installed firmware to the newest one and I even tried API mode (with escape and without escape.) however I did not get anything. I think I did everything I could.

Personally I think this is not a hardware issue. I am using 4 xbees and I tested with different Antennas which I have and I even used two laptops with different OS. Would there I could do more?

I would suggest that you restore both units to defaults.