Mixed API and Transparent Modes

Hi there, I have 2 XBEE Modems, Series 2, one programmed as “ZNET 2.5 Router/End Device API”, and one “ZNET 2.5 Coordinator API”. When I power them up, the End Device appears to associate OK. (The Associate LED blinks at 2hx). This End Device is attached to an Arduino, and is programmed to continually transmit a small payload “XBee”, using the Ardiono XBee API.

I am linking to the coordinator XBEE using a terminal emulator. I can “+++”, (It’s not in API mode), and “ATND”, and I see my end device listed.

But… I never see any data coming through the coordinator. I would have expected to see raw API frames appearing on the terminal screen…

Am I missing something obvious here? My next step is to remove the end device from the arduino and attach to a PC, so I can program it in Java and check things like return codes from the transmit api, but before I do, I just wanted to see whether I am missing something obvious.


Please post the full API packet that you are sending to the end device from the Ardiono.

Hi FordCF2000,
I can’t post the API packet right now, as I was using a library for the ARDUINO, and I can’t really see what it generates. Anyway, I have moved on a bit, and I was wondering if you would be kind enough to help me again.

I now have a coordinator xbee on my mac, and am using java and rxtx, to talk to it in API mode. My other xbee is an end device, also API mode. If I run a ND AT command from the coordinator, I can see the other xbee. (Called BOILER). Progress indeed!

However, I would now like to send some data, and I wanted to send it to the loopback cluster id. I send the ExplicitTxRequest, but I get a delivery status of ADDRESS_NOT_FOUND. (I have the correct 64 bit address)

Upon closer reading of the manual, I see that application layer addressing is only supported in API firmware.

So, before I go flashing again, can you tell me, is it ok to keep the coordinator XBEE in API mode, because I have great flexibility to program it in Java, and just change the BOILER xbee to API mode? (It will be on an ARDUINO anyway, and I dont need it to do much.)

Thanks again for helping.


Just tried another example from the XBee API library, this time doing a Synchronous send, and it works fine, as in I get a succesful delivery notification. So, it appears to be something to do with sending in Explicit mode, or using Application layer addressing.

Back to the manual I guess…