Net os7.4 and the SMTP email sample

I am trying to understand how the SMTP server works and what it’s limitations are. but so far Digi is beating me up again, I would appreciate it if someone could explain the following behavior to me.

using the “Email Services Sample” I have tried the following.
user account for GMail Pop, Yahoo, and our own email.

The results I get are Gmail and Yahoo don’t work at all. so I am guesing they use some form a login security that NetOs7.4 doesn’t support.

GMX only sends message 6, using Digest MD5 authentication. so I think I get that requires MD5 authentication, and the other messages doesn’t set the authentication.

But what completely baffles me is when using our internal email, I only get, messages 3, 4, and 6. Looking through the code the only thing 3, 4 and 6 have in common that the others don’t is that they attach 1 or more files. message 5 attaches a file too but it uses a different api then the others (MCAdd_FileAttachment instead of MCAdd_Attachment) Can anyone explain this to me?

Since the email settings will need to be set up by the end user I really need a good explanation on how to write solid code on sending an email, as I have no control over the End Users Email server.

Yes, the Digi SMTP does NOT support TLS (SSL) so GMail, Yahoo, and the like don’t work. (It should, OpenSSL is part of NetOS, but someone got lazy.)

As for attachments, I haven’t used those with the MC API.


Thanks that’s what I thought about gmail and yahoo. and about the attached files that’s the funny thing, I really don’t need to send files just a text email. (my luck if I wanted to send them that would be the part that wouldn’t work, but since i don’t want to it does and plain emails don’t)

I have confirmed that it is the MCAdd_Attachment api that causes an email to be sent. if I remove that one call the message no longer gets sent. Any ideas?


Not sure if this will help you, but I have attached the deatails of the main routines that I use to send e-mails. This has worked for me with or without attached files