Problem in connecting the Rabbit processor to our Lan Network

Hi all,
We are working on the project called Lighting system.We have used Rabbit4000 processor in our project as it has inbuilt ethernet facility.We are able to communicate Rabbit processor(Server) through PC(Client) by giving IP addressand Port Number through Ethernet Cross cable.This is one to one connection between PC and Rabbitprocessor .We have used free TCP/IP stack provided by rabbit to achieve this using Socket functions.This setup(One to One connection) is working fine.
But now we require Rabbit processor(Server) to be connected to our Office network so that we can communicate the rabbit processor(server) with any of the PC in our office.But we tried this by connecting Rabbit processor to our LAN and tried to Ping the rabbit from one of the PC in our office but not able communicate.We are giving only IP and Port address for configuration.
Our office network works on domain server principle.Where all PCs in our office is member to this Domain Server .

So please any one help us to know what to do in order to communicate the Rabbit processor through our office network.
Please note we are not using HTTP and we require solution without using HTTP.Because HTTP uses OS which will be complicated and time consuming.

Please help us in this regard.

Thanks & Regards

I’m seeing a similar problem:

  • My RCM4000 server app runs fine with a direct connection and a crossover cable to a client system.

  • When I go through a switch, it seems that the RCM4000 isn’t responding to discovery queries. Unfortunately I can’t view the network traffic and the promiscuous hub I have isn’t working at all with the RCM4000 (speed difference I suspect).

  • The network link lights on both the RCM4000 and the switch indicate network connection OK.

  • Is there a call to make to enable the RCM4000 to respond to the discovery queries (ARP/Who has XXX)?

Any enlightenment appreciated.

It turns out that the problem I was having lay in the port I was using on my ethernet switch. Either it’s bad, or intended to be an uplink. Moved the RCM4000 network cable to a different jack and everything works as expected.

hey guys
can u give me ur email ids?
i m working on similar kind of project, i e communicate Rabbit processor through PC
so that i can get in touch wid u.
so can u help me?
i want the help related to the code