Problem to create thread with NetOS 7.4.2

Since I update NetOs with the version 7.4.2 from the version 7.4.1, all my applications where I use the function tx_thread_create don’t work. Even the example “Ftp Client Sample” doesn’t work.

Can you help me? I don’t have any solution to solve my problem.

You mention in your title that you are having trouble creating threads. Can you report what error condition is returned from calls to tx_thread_create. Can you put together a quick small application that creates one thread? Are you able to do that?

Make sure you’re not running into the problem described here:,2733#8761

There is no error when I call tx_thread_create, the return is TX_SUCCESS but the connectme module is blocked just after.

I tried with a simple project from Digi examples “Ftp Client Sample”, and I have the same problem.

I just tried to follow the procedure define in this page, but it doesn’t solve my problem.

Make sure you have the very latest patches installed (i.e. the most current plugin patch)