RHEL 7.3 realport drivers

Can anyone assist me with getting the realport drivers built on a RHEL 7.3 , I tried both stock drivers and also the BETA release, that was mentioned in another post ( ftp://ftp1.digi.com/support/beta/linux/dgrp/40002086_X2P.src.rpm)

I am stuck at the same error of TTY_CLOSING during make on both sets.

/root/rpmbuild/BUILD/dgrp-1.9/driver/build/dgrp_net_ops.c: In function ‘dgrp_input’:
/root/rpmbuild/BUILD/dgrp-1.9/driver/build/dgrp_net_ops.c:535:31: error: ‘TTY_CLOSING’ undeclared (first use in this function)
if (tty->closing || test_bit(TTY_CLOSING, &tty->flags))
./arch/x86/include/asm/bitops.h:344:25: note: in definition of macro ‘test_bit’
/root/rpmbuild/BUILD/dgrp-1.9/driver/build/dgrp_net_ops.c:535:31: note: each undeclared identifier is reported only once for each function it appears in
if (tty->closing || test_bit(TTY_CLOSING, &tty->flags))
./arch/x86/include/asm/bitops.h:344:25: note: in definition of macro ‘test_bit’
make[3]: *** [/root/rpmbuild/BUILD/dgrp-1.9/driver/build/dgrp_net_ops.o] Error 1
make[2]: *** [module/root/rpmbuild/BUILD/dgrp-1.9/driver/build] Error 2
make[2]: Leaving directory /usr/src/kernels/3.10.0-514.2.2.el7.x86_64' make[1]: *** [build] Error 2 make[1]: Leaving directory /root/rpmbuild/BUILD/dgrp-1.9/driver/2.6.27’
make: *** [build] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.cpIXzZ (%build)

I can report the following:

On a fresh install, RHEL 7.3 kernel version 3.10.0-123.el7 it compiles fine. Once updated to kernel 3.10.0-514.2.2.el7, it breaks.

I was running into the exact same issue. Email Tech.Support@digi.com and tell them that you need the dgrp-1.9-37 version of the driver. also, you will probably need to yum psmisc-22.20-11.el7.x86_64 before the driver will install because my server did not have the command fuser on it, and the digi install would fail on that.

I am still trying to get my unit operational now that the software is installed, but will happily share any other info i may discover should you request it. Thank you.

I can confirm that the 1-9.37 version of the driver does install on the 3.10.0-514.2.2.el7 kernel.

so 1.9.37 is by demand only ? I have to ask these guys ?

It would appear so, as they still have not posted them to the website as of yet. Thank you.

Just patch the constant in like I did for the Arch Linux package.

echo “#define TTY_CLOSING (7)” >> ‘driver/build/include/dgrp_net_ops.h’

It’s not a permanent solution since whatever this constant did probably doesn’t work any more. I’m glad to hear that the next version is begin worked on.

Look at the PKGBUILD on the Arch Linux AUR for any more information.

Just ran into myself,

RHEL Access says contact vendor
Check out the digi RealPort version dgrp-1.9-37.src.rpm_y1p by contacting the vendor.

I have opened a case with Digi

Red Hat Enterprise Linux Server release 7.3 (Maipo)

Attempted to build 40002086_X.src.rpm

Digi Support provided a fix that seems to be working

-rw-r–r-- 1 root root 4410219 Jan 18 09:03 dgrp-1.9-37.src.rpm
-rw-r–r-- 1 root root 4397165 Jan 18 09:03 dgrp-1.9-37.tgz
-rw-r–r-- 1 root root 24826 Jan 18 09:03 release_notes.txt

a63ba04c28dde0d6b413145b53aab102 dgrp-1.9-37.src.rpm
31f07bf27cb2c664e92a9bf8cc63038c dgrp-1.9-37.tgz
7cb916441d59ec9281f75d44599b2847 release_notes.txt

Thanks Digi Support,

Contact digi for get the required files

Hopefully they will get it on their download site.


1 Like

How do I go about getting that file? Digi support can’t seem to find it today. Could you dropbox it to us or something? Pretty please!?! I tried searching their FTP server with Filezilla find, but no luck.

Please reach out to digi again Digi case: 00274969 working with JEREMY MCBANE . Last status I have is they are still working to get it up on their website…

From Digi:

Want to let you know that we put these files on our site:


The above URL is from the URL below (after you select Linux for the OS):


Thanks for your continued patience while we were working on this!

Go Digi Support!