Unable to disable NAT for Mobile interface in WR21

It seems that NAT is still operational though I disabled it from the Interface settings: ‘Mobile network settings’ -> ‘Enable NAT on this interface’ -> checkbox cleared.
What might be reason that NAT is still working?


If you have applied the change on the PPP interface in some cases you have to drop the PPP interface to accept the change.

have you checked with the analyser that the packets out of the PPP interface are still being natted



Thank you for the answer. Rebooting the device after making the NAT change enabled it, so it seems that the interface needs a restart / reboot that the NAT goes on or off.