Xbee S2C XB24C with Phillips Hue Light Bulb

Hello to everybody,

Recently I bought Digi Xbee S2C XB24C module together with SparkFun XBee Explorer Dongle USB, so I can easily attach it to my MacBook Pro laptop.




First thing I have done so far is that I installed latest available version of XCTU app, which is by the way great and very powerful tool.

I was able to detect my Xbee device, so I updated it to latest available firmware.

Device is recognised as ZigBee TH Reg, CE is enabled to 1, AP as well, security enabled etc.

As well parallel I bough single Phillips Hue Bulb, which was never paired with any Phillips Hue Hub’s.

XCTU Tool see it, and my Xbee device automatically create network with it.

Issue that I am facing is that when I double click on Phillips Hue bulb, XCTU start to initialize data for new device, but it always fail, and display message that data cannot be initialised.

Second issue is that I was not able to find any commands which I can send over console to make my Bulb turn Off.

Can somebody explain in short what could be reason that I am not able to send any command because all answers I get is that command is invalid.


1 Like

Try starting with http://knowledge.digi.com/articles/Knowledge_Base_Article/Zigbee-Home-Automation/?q=HA Home+Automation&l=en_US&fs=Search&pn=1

Next, you are going to need to do some reading on both the Phillips device as well as the XBee module on how to send API frames. The phillips device should have data on what ZDO or Zigbee device objects you need to send while the Digi API will tell you how to assemble the API frame for the XBee to send that ZDO command.


Thanks for fast answer. I already manage to make it working using node-red (node.js) and following this tutorial:


It actually works good with Phillips Hue and Osram Lightify bulbs.

Just I am not yet aware, what commands and appropriate format of command that is sent.

It is for sure Remote AT command targeting MAC Address of each Bulb.

I am also trying the same thing but my XBEE S2C is not discovering hue bulb (Factory resetted using hue bridge).
I have tried the same configuration as mentioned in https://github.com/ratmandu/node-red-contrib-zblight , But my XBEEs are not dicovering bulb.

Any help is highly appreciated.

thank you


Can I have more information about how it worked, I’m facing the same issue.

Thank you.

Hello , i am trying to do the same but with XBee S1 and esp32 to control the Philips hue with bridge .
is there any links or idea or video for that please.