9xtend @900 Mhz data rate problem

This is my first post so i apologize in advance if i write something that looks strange.
I have been working with Xbee pro and 9Xtend modems for a sufficient long time but i came across a problem that made me wonder.
I tried to transfer (upload) some data with a rate of 5 bytes every 20 ms using a couple of 9Xtend modems set at 115200bps (900 Mhz hopping with mostly factory default settings)
but the modems are unable to transfer those bytes in time.
Also when i try to move those bytes the download link is also lost and restored respectively every ~4 seconds acting much like the modems get congested or out of sync.
By using a lower upload data traffic the download link is restored and i do have almost real time
two way communication again.
When i use two Xbee pro modems at 2.4 Ghz instead everything works like a charm less the range which is the main reason that made me chose the 9xtend modems.
It almost looks like the latency is too high or the actual baud rate is much lower than 115200,
lower than 9600 bps.

Any help or ideas to try welcomed.

Try increasing the 20ms time between packets. Try having more data in fewer packets. It’s possible you are running the RF buffers out.

I will try those recommendations thank you.
I am also thinking lowering the rf power, as i am experimenting in close range maybe the modem’s front end gets saturated.
So far i have tried the addressed mode by giving the two modems a unique address
but i have noticed that the buffers go from 800 to 100 when i leave the broadcasting mode (default settings) and use the addressing mode.
I also tried going down in baud rate from 115200 to 9600 bps and lower the retries to 1
from the default “A” times but with no luck.
Generally It looks like the modem is entering transmit mode and has a hard time finding free time to enter receive mode hence the lost link indication i get.
This got worst when i switched from 115200 to 9600 bps.

I tried everything but i get the same behavior.
Meanwhile i found somebody in France that had the same problem and after he contacted Digi
they send him a modified firmware that solved the problem so the problem is known to the Digi tech department…
He and me are trying to do the same thing on the same hardware
(pass a PC connected joystick information to the modem and send it to a UAV.
Now i use a dedicated long range rc system but i already have telemetry and the joystick values
can be passed through the modem easily as it only involves a few bytes every 25ms (about 2400bps in total)
I am trying to get hold of this firmware,

I have exactly the same problem! But I’m trying transfer some data (78 bytes) every 10ms using a couple of 9xtend (422 interface). But the modems are unable to transfer those bytes in time. I tried everything too, every configuration, and no luck! This modified firmware exists???