acceleport Xr 920 and hanging processes

Have an acceleport Xr 920 in a box running RH 7.0 which is used as a dial in server for e-mail. USRobotics modems are connected to the ports.

Problems occur when modem drops because of a modem to modem error. The shell that is started do not automatically terminate which it does if the the modem is connected to a ttyS* port. Have worked around this by setting an idle timeout in the shell, but this is not a good solution.

I’m using the 1.50-1 driver and I have tried the 1.56-1 driver, but there is still the same problem.

Do someone know if this is a problem with the digiboard or if it is a linux problem?

Best regards

Sounds like DCD is not dropping on the Digi port to signal a modem drop to the O.S.

If you are using an 8-wire cable, make sure you implement the altpin setting:

ditty altpin ttyD###

You can monitor the DCD signal activity using the “dpa” utility (simply type dpa at the Linux root prompt). The DCD signal should raise once a modem connection is established and drop when the modem disconnects. If the modem is not raising/dropping DCD in this fashion, please refer to your US Robotics modem settings for normal DCD/Carrier behavior.

Hope this helps.