ADC problem


I’m using a module to sample an analog signal (40 samples before tx), then send the data to a coordinator connected to a PC and plot the signal using a LabView software.

The problem is that when the input voltage reaches a value n times Vref/4 the coordinator receives less than the 40 samples it is supposed to receive (if Vref is 2.8V, the error occurs at Vin= 0.7V,1.4V and 2.1V). Don’t know if that is just a coincidence or there is something wrong with the ADC.
It seems like instead of building the API frame the module just sends only the converted value as in transparent mode.

The boards I’m using are fine, the sampling rate is 250Hz, the input signal is a voltage that I controll with a potentiometer.
Any help will be appreciated.

That’s weird, and I don’t know the answer.

A suggestion, though, would be to reduce the sample rate - say to 5Hz. Do you still get the same problem, or do the symptoms change?

The answer to that might provide a helpful clue.

Also: what firmware version are you using?

Hi Jhon,

Yes that was wierd, but I solved it. The modules were ok, it was a software issue. Turned out that some hexadecimal values from the ADC ended with 0D which is ASCII for carriage return and my software saw it as a termination character. thanks for the answer