After upgrade Passport to 1.5.0, can't login using root to CLI on SSH

, , ,

Hi!

I upgraded a bunch of Passports to the latest 1.5.0 code (82001329_L.bin) and noticed this issue after.

Before the upgrades, I could login with “root” over SSH to port 22 of the Passport, and I would be rewarded with a CLI. However, after the upgrade, I can no longer do so.

The root user works fine on the Web, and also via “SU -” if I setup another CLI user. The messages file says:

Nov 20 13:01:08 Digi_Passport pam_local_auth: session opened for user root by (uid=0)
Nov 20 13:01:08 Digi_Passport sshd: LOCAL - SSH authentication for ‘root’ passed.

but the SSH client sees this instead:

unixbox$ ssh -l root 10.2.3.4
root@10.2.3.4’s password:
Permission denied, please try again.

The config didn’t change, as it was a simple “Upgrade Firmware”, and post reboot this is the case. PAM/SSHD seem ok with the password, but the user can’t login. SSH is working otherwise, like I said if I create a new user with CLI rights, and I SU from there…

And, you probably know, the /etc/sshd_config contains the line:
#PermitRootLogin yes

What’s going on?

Thanks!
Ian.

  1. Change the “PermitRootLogin” option to yes and take out the “#” in /etc/ssh/sshd_config
    PermitRootLogin yes

  2. run “saveconf” command in the CLI.

  3. Restart “SSHD” by running the following command in the CLI

service sshd restart

Or simply reboot the system again.

Hi RonK,

For the record, I needed to reboot the box in order for the change to take. The service restart didn’t work for this keyword.

Thanks for your information!