All LEDs on Transport WR44 (beside LANs) flickers all the time after (new from box) I powered up. Can't re-flash.

If you have tried FlashWriter and it still blinks, it is likely a hardware problem. Please contact Digi support for an RMA.

Try reflashing the device using serial and eth as it will be able to recover the unit.
Flashwriter loads a complete image of the flash structure, in the form of a “.all file”, into the router’s flash memory, replacing the current flash contents and therefore is usually able to recover a corrupt unit.

Thanks sans0909,
As I posted, I tried to flash but no connection is established.
I tried the PC serial port and even bought a USB-RS232 adaptor and tried it too but with no connection.
The digi transport moudle is WR44-U5 and on its front panel there is the title: “Powered by Sarian systems”.

  1. Therefore, is it a digi transport or legacy Sarian system router?
  2. Since its the first time I’m flashing, Is there a specfic way of doing it? (I saw apost about DR64:

I was able to re-flash by using the serial-USB converter only after changing its com number to 1 (instead of 11 as originally). It seems that the FlashWrite program can’t use port other than com1.
After flashing, no W-WAN can be found although a gobi2000 module is installed.:frowning: