Arduino Digimesh Pro 900HP issue.

I have been using Xbee Pro XSC 900mhz(XBP9B-XCST-002) for a while now doing point to point wireless communication with arduinos on either side. It has been working great. They both use custom boards/shields for the xbee mount. No API, just straight serial communication.

I am now attempting to move to mesh with these devices. The xbee I am using for the mesh is the Xbee-Pro 900HP (XBP9B-DMST-002) with the digimesh firmware version 8071. I am configuring them with the following:

Base Station: (receiving)
ID: 1
AP:1 ( API Mode without escapes) (have tried 2, also with same results)

Node: (sending)
ID: 1
AP: 0 - Transparent Mode

When connected to two different USB explorers on two different computers, I can send data well from the node to the base station. As soon as I type a keystroke on the node console the Base Station console shows the incoming packing perfectly.

When I take the node module and put it into my arduino shield, my program is attempting to transmit as always, but nothing ever shows up on the base station console on the computer. In the arduino I am doing a basic serial3 println. I even reversed the modules and had the Base station in the arduino with it listening on serial3 and used the computer as the node and input serial text through, XCTU, but never printed anything out. As stated before this worked fine with the XSC modules, but will not work with the new 900hp one using digimesh. As I understand it, I don’t have to use any arudino Library to send data from the node, although I did try this incase it was the issue. My custom board only has pin connections on VCC, GND, DOUT & DIN, but the documentation sheet says that’s all you need unless you are going to push firmware remotely.

Any thoughts would be appreciated.

Start by restoring both to defaults and then just set the DL and DH of each radio to match the SL and SH of the other. Then just send your transparent data. Make sure you are using the proper baud rate, in this case 9600 otherwise you will not receive anything.

1 Like

Thanks for the tip. Reset both of my units… and the only settings I used was the DH and DL as suggested. I put both in usb explorers in two different laptops and they talked nicely. I removed form from the usb xbee explorer and placed it in my arduino shield and nothing. Wouldn’t receive any data or print any new data. I have the arduino 2.0 shield coming tomorrow that I will test it to be sure it’s not a custom hardware board thing.

I would appreciate any more thoughts.

Providing it is not a baud rate thing, this should just work. Just as you saw.

new arduino shield has the exact same behavior. Works fine for the XSC module, but will not work with the Pro 900HP.

Are you using API mode?

I have tried API mode on one and transparent on the other. and I’ve also tried transparent on both.

I do have an update. I just realized that all of my modules are actually the programmable version. XBP9B-DMSTB002 revE . I’m sorry for not realizing this earlier. Might this make a difference?

Yes that would make a Huge difference. Think of it this way, what happens when you connect to mC together? One with code on it and the other with nothing on it. That is effectively what you are doing with the programmable versions. At least till you load some sort of code on the FreeScale processor that comes on the programmable versions.

Got the new non-programmable modules in and they work perfectly. Thank you for all of the help and I’m sorry that I didn’t realize earlier the module issue.

Hi maker_rf
I am in the same situation like you one year ago.
Can you help me to understand better the difference between PRO and NON-PRO versions? I have the 900HP-PRO version and I want to use them to transfer data between two arduinos.

  1. Question: can you give me the partnumber or the non-pro version?
  2. Question: there is a change to be able to use the PRO version for my purpose?

Much appreciated,