Auto-IP Configuration

Hi All,

I have been working weith NetOS on the Digi Connect ME for some time. The modules that I have set up to use DHCP operate fine and on boot - up send out the correct DHCP request, get thier address and accept the DHCP options for DNS Servers and set up the DNS servers correctly.

I have just had a new batch of ME module in. I have put exactly the same application in these modules and set the network up for DHCP. These modules however boot up and then set an Auto-IP at the prior to getting DHCP as follows.

Retrieving debug data from unit at, UDP debug port 12345.
IAM:Got AUTO-CONFIGURED IPv6 address FE80::240:9DFF:FE34:8B34 on interface eth0:3
IAM:Got AUTOIP IPv4 address on interface eth0:0
IAM:Got DHCP IPv4 address on interface eth0
Network IP configured.

It then seems that the DNS options returned by the DHCP server are not properly set up.

I think this may be due to some setting in the NV parameters in the new units that is calling for Auto IP. The standard Network paramettr setting in the CLI, HTTPServer and the Finder app do not seem to allow settings for AUTO IP, in the NV RAM.

Has anyone else come across this and if so any ideas on how to control Auto IP settings, and getting DNS from the DHCP Options


Hi Roy,

Did you ever find a solution to your problem? I have had a problem with our Connect-ME units not geting an IP address through DHCP when connected to a busy network with a large subnet mask (

Thank you,

Make sure you’re running the latest patches, as that should correct the problems you’re seeing. Also, you can disable autoIP (which typically is enabled on eth0:0) by disabling the interface. You can use customizeIamGetConfig to get the interfaces config, customizeIamFindInterfaceConfig to find the interface config for “eth0:0”, and then change the config params to disable it, and then write it back to NVRAM with customizeIamSetInterfaceConfig