Can I change to Win CE 6.0 R3

Hello,

I just got a Win CE 6.0 R3 installation disk and wonder if I can install it while still working with a CC9M2443 which is based on R2. Do I need a new BSP and SDK then? Must I create a new image? Is there any advantage or even influence on the application development?

Thank you for any answers

Martin

Hello Martin,

shouldn’t be a problem to update to CE 6.0 R3.
I did it already.

Adds some new features to CE accessible via platform builder.

  • .Net 3.5 support
  • SQL Compact 3.5

  • You don’t need a new BSP but you have to rebuild your kernel if you want to use this features.

To develop applications with .Net 3.5 you have to use VS 2008.
For kernel development you must still use VS2005.

Greetings
Hermann

P.S.: I hope all given information is correct because I am although new to this topic.

Hi,
If you install the R3 it will resolve the old issues, and it support some new features. So it is better to install R3 and monthly updates also.

You may want to update the BSP as well. There have been some new features and patches.

http://www.digi.com/support/productdetl.jsp?pid=5025&osvid=140&tp=9&s=582&tp2=0

ftp://ftp1.digi.com/support/images/connect/wce/iso/40002739_C.iso

You may want to update the BSP as well. There have been some new features and patches.

http://www.digi.com/support/productdetl.jsp?pid=5025&osvid=140&tp=9&s=582&tp2=0

ftp://ftp1.digi.com/support/images/connect/wce/iso/40002739_C.iso

I know I am bringing back an old thread but tried to install this new BSP but I can only choose between ConnectCore i.MX51 or Wi-i.MX and I am using ConnectCore 9M2443

First unisntall the old ConnectCore SDK’s and Digi jumpstart kit for windows embedded CE 6.0 from the programs and features then install the new BSP.