Can't install my application: neither uSD Card Slot nor USB work

I have two iMX53 with stock Android image. I noticed that there is file manager application installed and I thought I could use it to install additional applications from uSD card. However, it appears that uSD card is completely ignored.

I have tried with several uSD (128 Mb, 1 GB and 8 GB) cards on both boards with no luck. I tried PC formatted cards (FAT) as well as a card formatted by an Android phone. What it looks like is that the card insertion is completely ignored – as if file manager does not receive insertion event at all.

Since both boards are affected I was wondering if card slot is somehow disabled by default?

To make things worse, I can’t really use USB for debugging either as my Win7 laptop fails to recognize the device (it works fine with assortment of other Android phones and tablets).

Hello Them,

The stock Android image includes the ES file explorer application, which lets you navigate through the file system and install applications from mounted devices.

When you insert an SDCard, it should be automatically mounted in /mnt/sdcard folder. The uSD card is automatically mounted in /mnt/extsd and the USB stick is mounted in /mnt/udisk.

Could you check using the serial connection if there is something under these folders after you inser the card/usb? Also, could you send us the dmesg output after inserting them?

You can try another thing which is to insert an SDCard and then the uSD, I remember some problems with the uSD where you need to insert an SDCard first in order to get the uSD mounted. If that still not works try to reboot the device with the cards inserted and check again.

I have several setups here with stock images and all are correclty mounting SD/uSD cards.

Kind regards.

Hi descalon,

Thanks for the reply!

I’m away at the moment so cannot test this but I think I see from your reply what the problem may be – I was inserting uSD card and looking into /mnt/sdcard instead of /mnt/extsd! I’ll try that as soon as I have a chance.

Also, neither of my boards has SD Card slot on board – there is a place for it on the board but it has not been installed. I only have uSD Card slot.


I am experiencing similar problems to ‘them’. I can get ES File Explorer to see the uSD card though it took a while to figure out how to find it. It is not seen as sdcard but extsd and it does not seem possible to browse to it, but under the starred icon in the ES File Explorer toolbar is one line that says /mnt/extsd/) and that reads the uSD. But the extsd does not mount as an ordinary sdcard so Android apps do not see it and installs that need the sdcard don’t work. Is there a way to make the uSD be treated as conventional SD?


As you pointed, Android expects “/mnt/sdcard” to be the default external storage directory. As no SD can be inserted, Android considers itself to have no external storage device available.

Until we work on a solution to allow the selection of the default external storage device, here is a workaround to detect the uSD card as SD card:

You have to edit the file “/system/etc/vold.fstab” and perform the following actions:

  • comment this line out:
# dev_mount sdcard /mnt/sdcard auto /devices/platform/mxsdhci.1/mmc_host/mmc0
  • modify this other line:
dev_mount extsd /mnt/sdcard auto /devices/platform/mxsdhci.2/mmc_host/mmc1

So finally you should have this:

# dev_mount sdcard /mnt/sdcard auto /devices/platform/mxsdhci.1/mmc_host/mmc0
dev_mount extsd /mnt/sdcard auto /devices/platform/mxsdhci.2/mmc_host/mmc1

After that, reboot the system. Once Android boots again, you will have your uSD card mounted as SD card, being able to perform all default SD card operations such as media scan, gallery and application install.

Kind regards.