Can't program eMMC on ConnectCore 8M Mini Dev Kit

I have a new ConnectCore 8M Mini dev kit. I’m trying to program the eMMC for the first time and it isn’t working for me. I was wondering if someone had run into this problem before and knows what to do.

I’ve been following the Get Started Guide instructions here: Step 3 - Program the Yocto firmware | ConnectCore 8M Mini. I’m having problems with step 10 with programming the firmware using UUU. When I run the script (default settings, no options), I get the error message:


on the uuu calls in the script. I’ve tried two different Linux machines and I’m getting the same results. Anyone else seeing this problem? If so, any idea on how to fix it?

sounds like a connection issue between PC and the target over USB. Are you doing this on a physical Linux machine or some kind of VM/docker etc?
To save time I recommend updating via MicroSD card for now.

I’m using a VM. If the Linux VM doesn’t have access to the recovery USB port then the hangs indefinitely waiting to find the recovery USB connection. If the Linux VM does have access to the recovery USB port then I get the libusb timeout error within a second of each uuu command executing.

I was able to program the eMMC using the microSD card. This works, but we would still like to get it working with UUU over the recovery USB port. We do not plan on including the microSD interface on our final product and we would like to perform the initial programming over USB.