Configuration of API mode Receiving only RF data on the UART, not whole packet

Hey all,

been working successfully with a few XBEE Pro S2C in API mode… for some reason now i am getting the entire packet on the UART (0x73 to Checksum). Previously I was just getting the contents of the RF Data portion on the packet on the UART.

My application is such that the RF data payload contains some binary data used to configure a hardware device.

The devices are all in API mode 1.

is there a setting that makes it send the RF data only to the local uart vs the entire packet?

I have a sending hardware device, a monitor device and a “snooper” radio on a laptop with XCTU verifying the sender is actually sending. Im seeing the entire packet on the UART on the monitor, instead of just the RF payload.