pb with RF module in API mode

I have two Xbee modules which correctly send and receive data in transparent mode (parameter AP=0), but no data is received (sent?) in API mode (when I set AP=1)!!! What could be the problem? Any idea?

one module is plugged on xbib-u-dev board and data is displayed with XCTU soft, the other module is plugged in my dev board which write data via serial link of a µcontroler.
firmware version is 10E6 on the two module.
All is ok in transparent mode (data received are the data send), but nothing in API mode! Test frame data is
7E 00 0A 01 00 10 00 01 48 65 6C 6C 6F 88

Well, here’s what packet-check says about that packet. Fix the checksum and things should get a bit better… (packets with incorrect checksums are silently ignored).

[john@eccles ~]$ packet-check
API Packet analyzer version 1.2 for Series 1 XBee (802.15.4)
Note: if it prompts for more bytes and you’re done, hit return
Enter packet: 7E 00 0A 01 00 10 00 01 48 65 6C 6C 6F 88

Packet: 7E 00 0A 01 00 10 00 01 48 65 6C 6C 6F 88
7E // Correct packet header byte
00 0A // payload length (decimal 10)
01 // Packet type: TX request with 16-bit address
00 // frame id: 00 so no response packet will be sent
10 00 // 16-bit destination address
01 // TX options: Disable ACK
48 // transmitted data ‘H’
65 // transmitted data ‘e’
6C // transmitted data ‘l’
6C // transmitted data ‘l’
6F // transmitted data ‘o’
88 // checksum - SHOULD BE F9


  1. Incorrect checksum

thank you very much johnf. I took this frame from an exemple, I replaced the @ of remote, but I forgot to recalculate the checksum! Now it’s ok. thank you.