solved: XBee S1 - newbee API problem


at the moment I try to understand how XBee works. I have one XBee connected to the computer and one is wired just to send back (in transparent mode) everything it recieves (hard-wire connection between DIN and DOUT).

This is how far I got:
I put the XBee coordinator (connected to my computer) in transparent mode. Now everything I type into my terminal ist coming back. So long it works fine.

Next step:
I put my computer-connected coordinator in API mode (1). The remote XBee stays in transparent mode.

Now I send this package via terminal to my coordinator (all hex):

00 16 //lenght
10 //send data
00 00 00 00 00 00 FF FF // to every XBee in my network
00 00
54 78 44 61 74 61 30 41 // my data to be sent
C3 // checksum

but… nothing happens. (Of course I tried to modify my API package).

Where is my mistake?


Hello Sebastian,

Frame type 0x10 is not supported in XBee Series 1 (802.15.4), that frame type is for XBee Series 2 (ZigBee). Find here an API frame generator. The API frames to send in Series 1 are 0x00 and 0x01.

If that is not the problem, please be more explicit on what module, firmware and version are you referring to (use X-CTU for reading settings).

Best regards,

Yes! That’s it. Thanks a lot.