ConnectCore 6UL SBC Pro DEY 3.0 R.2 microphone not working

I updated the firmware of my to most recent version.
I connected a capacitive mic to mic pins of the card.
When I execute the below commands:
arecord --format=S16_LE --channels=1 --rate=44100 micro.wav --duration=10
aplay micro.wav
all I hear is a white noise.

I’ve tried with various levels of MIC1 and MIC2 input and boost levels. ( of course the level of noise decreases when I decrease MIC2 level and MIC2 boost level)
I have tried with several microphones.
Any suggestions are welcome.

Did it work with dey-3.0.r1? Have you tried this on a dev board?

No, it did not work with dey-3.0.r1 also.
dey-3.0.r1 image was the one that I’ve build myself with pulseaudio and etc added to it. I thought my image may be the problem so I updated the firmware with the Digi’s pre-built images. I’ve only tried on ConnectCore 6UL SBC Pro 1GB flash 1GB RAM version. Thank you.

are you connecting your external microphone to 8-pin, 1.25 mm pitch expansion connector (J26). The following table shows the pinout of this connector:

Pin Signal name Description

1 MIC_N Microphone input negative signal

2 MIC_P Microphone input positive signal

To record a stereo WAV audio file with 10 seconds duration from line-in:

~# arecord -f cd sound.wav --duration 10

Yes I connected my microphone to first two pins of J26.
Since I connected my microphone to microphone pins, I used the command in my first my message to record sound.