DEL DigiESP 5.7 Device Manager / PASSIVE FTP transfer

On Eclipse Digi EL-5.7, using FTP file transfer (as defined in the Device Manager) does not work because we have a NAT server between Eclipse and the Digi target.
We noticed this FTP is active (HOST…) and there is no way to open NAT port in this mode.
We need PASSIVE FTP (which is by far preferred those days).
We had an extensive look at the different settings for Eclipse/CDT/Digi plugin as well as a look into /usr/local/DigiEL-5.7/digiesp files, just in case something could be tweaked. To no avail.
Any idea how to achieve this?

If you have NAT due to VM network settings, change it to bridged mode and it will be more straight forward. Naively digiESP does not support passive mode FTP.
Long time ago digi engineering has been trying to implement the passive mode to compile a new plug-in.
It was done for DEL 5.8.1. and might work for 5.7. you can try.

If the active mode fails, it will try in passive mode.

To install it:

  1. Close the Digi ESP if it is running.
  2. Uncompress the file to obtain a new one called com.digi.workbench_2.0.0.jar
  3. Go to the plugins directory of your Digi ESP, /digiesp/plugins (usually /usr/local/DEL-5.8/digiesp/plugins)
  4. Rename the file com.digi.workbench_2.0.0.jar to com.digi.workbench_2.0.0.jar-original not to lose it.
  5. Copy the uncompressed file to the plugins directory.
  6. Execute the Digi ESP with –clean option:
    • Open a terminal window and execute the command

#> /usr/local/DigiEL-5.8/digiesp/digiesp –clean &

1 Like

Thank you very much Leonid. That’s neat.
I tried hard with bridged mode but the USB-to-Ethernet coupler (a VK-QF9700 namely) resists any attempt to make it work in guest Kubuntu.
So it is the com.digi.workbench plugin that manages the FTP upload. I will try the upgrade and let you know.

I tried your advice. It works plenty well.
Thank you so much, Leonid.
Now maybe I have a more general question about DigiEL. I will discuss it into another topic.
Have a good one.

no problem, if you are satisfied with the answer, please mark it as “selected”

Oh yes, sorry. I up-voted and didn’t notice I can also check it as selected. That’s done!