Digi ESP changing permssion level & permssion denied

I have downloaded and setup Digi ESP for the ConnectME 9210 BSP. I can compile and debug the application with success on the first run though with Digi ESP.

If I close Digi ESP and return later to compile and download the same application with no changes, I get an error message indicating “Permission denied” to specific connectme9210 directories.

I manually change the permssions in Windows 10 and when I compile and download with debug I get the same error and it appears Digi ESP changed the permissions back so that I am denied access. I am running as the administrator on the PC.

Any idea why Digi ESP is changing the permissions and then preventing itself from accessing the files in its own directory??

Below is the error message:

make -k -s -j8 all

Building Bsp
rm: cannot remove /cygdrive/C/netos75/src/bsp/platforms/connectme9210_esp/lib': Permission denied /cygdrive/C/cygwin420/bin/mkdir: cannot create directory /cygdrive/C/netos75/src/bsp/platforms/connectme9210_esp’: File exists
make: *** [bsp/7_5/connectme9210/lib/libbsp.a] Error 1
make: Target `all’ not remade because of errors.

When you invoke DigiESP right click on the icon and select “Run as Administrator” from the dropdown menu. If this doesn’t work just verify you have only one version of Cygwin on your pc. Try building using the command line shell script. You will find the shell windows under Programs–>Digi–>Digi NET+OS 7.5–>GNU Tools–>Digi NET+OS Build Environment.

Hi Campbell,

Thank you very much for the intel!

I am running Windows 10:

  1. “Run as Administrator” had no effect and the same message with “Permission denied” still occurred with the connectme9210_esp directory.
  2. I checked and I could only see that Cygwin was installed by DigiESP only, I believe. Is there another method to check?
  3. The shell window you reference is no where to be seen in the Windows 10 program directory.

I gave up on Windows 10 and installed the software on a Windows 7 machine.

  1. Ran into the same error message again in the same fashion as with Windows 10. This time I used “Run as Adminstrator” and the result provided success and the “Permission denied” message did not occur.
  2. Cygwin was only install by DigiESP, so good on this point.
  3. The Shell Window location you reference matches the program directory structure in Windows 7. Was able to find and execute.

Your information seem applicable to Windows 7 and proved successful. However, for Windows 10 the information did not provide positive or successful results.

It appears DigiESP has a problems with permissions on Windows 10. Any additional helpful direction to resolve this issue for DigiESP on a Windows 10 OS??

I am running DigiESP with NET+OS 7.5 with latest patches on a Windows 10 Enterprise edition with a 64bit system. You should not have this permissions issue. I would try either of these; run DigiESP in compatability mode, you can do this by right clicking on DigiESP icon and selecting properties, then go to Compatbility tab and select Windows 7, check the box and also in same tab select Run as administrator.
Or you can uninstall and reinstall DigiESP, this time as your are installing verify that you give access to all users and make sure that your are logged in as the user you will be using mostly with admin priviliges.

per C:
NET+OS 7.5 supports the following Microsoft operating systems:
- Microsoft Windows XP (32-bit)
- Microsoft Windows Vista (32-bit)
- Microsoft Windows 7 (32-bit)

Windows 10 is not officially supported. It works in 99.9% of the setups but some setups have some issues due to compatibility with cygwin version used by netos. most of the time this issue is resolved if you run netos installer as administrator and then change preferences of the Digi ESP to run as administrator.
If this does not help change properties of:
and potentially others there to run as administrator.
If neither this nor clean uninstall and reinstall work, please use a supported version of windows.