Error following BSP upgrade

I’ve just downloaded the latest BSP upgrades and, following the hints given by the operating system, have tried to create a new application Workspace into which I will subsequently re-import my custom routines.

However, the newly-created application won’t compile. During compilation, I get the error messages:

…/…/ …/…/src/bsp/platforms/connectme9210_esp/Makefile.bsp: Permission denied
…/…/ *** You have entered an invalid platform, the valid platforms are: ns9750_a, ns9360_a, ns7520_a, ns9210_a, connectme9210, connectwiem9210, connectcore9p9215_a connectcorewi9p9215_a connectme, connectem, connectsp, connectwisp, connectwime, connectwiem, connectcore9c_a, connectcorewi9c_a, connectcore7u_a, connectcore9p9360_a. Stop.

This is from a pristine automatically-generated application which so far has had no input from me at all, other than pressing the “Build” button. So what can be happening here?


Update: the problem seems to go away if I run Digi ESP as an Administrator (for example by ticking the appropriate box in the shortcut’s “Properties/Advanced” menu). This didn’t seem to be necessary before, but at least I’ve got it working now.