ETIMEDOUT AWS - IOT using Micropython

Hello everyone,

I have an XBee 3 Cellular LTE-M/NB-IoT Global, firmware version L0.,A.02.01, with a Brazilian sim card.

Using the microPython, I’ve already tested with success those examples from digi: connection_status, ftp_client, http_request. However I can not connect to AWS IoT, but the test in my computer using my certificates worked fine.


PS C:\Users\user> & python c:/Users/user/Downloads/
HTTP/1.1 200 OK
content-type: application/json
content-length: 219
date: Wed, 23 Jun 2021 19:08:35 GMT
x-amzn-RequestId: ffa2cfbd-1510-0a1f6-0213-ebce1e95a2
connection: keep-alive



 | XBee MicroPython AWS HTTPS Sample |

- Waiting for the module to be connected to the cellular network... [OK]
- Connecting to AWS... Traceback (most recent call last):
  File "/flash/", line 134, in 
  File "/flash/", line 84, in https_test
OSError: [Errno 7110] ETIMEDOUT

I’ve used the certificate downloaded as instructed in another post in this forum ( and also the Starfield Services Root Certificate Authority - G2 from As mentioned, both of them working with the computer test, but not in the XBee, same behaviour with and without ‘-ats’ in my endpoint name.

Using the XBee, I always receive the OSError: [Errno 7110] ETIMEDOUT problem.

I’ve seen someone here asking another user to test the ATLA command with my endpoint and it returned the IP, so I think that it is working.

I’m currently trying to get the aws_http test to work.

Also tried

>>> import socket
>>> s = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
>>> s.connect((b'', 8883))
Traceback (most recent call last):
  File "", line 1, in 
OSError: [Errno 7110] ETIMEDOUT

ATVR 1141
ATMV L0.,A.02.01

May I suggest you start by updating the firmware versions you are working on. Then make sure that you are checking the status of the connection before you try to send the data.