File upload truncates some file names

Using Net+/OS with most recent patches on ME 9210, and have a strange problem when uploading files.
I have a web page, based on a Digi example, which allows the user to upload files into a specific directory within the flash file system. This has (apparently) worked for many years.
I’ve now tried to upload file “OFFSETS.TXT” - and it was stored with the first four characters of the file name removed - as “ETS.TXT”.
I’ve experimented with similar file names; “OFFLOAD.TXT”, “OXXSETS.TXT” and “OFFYETS.TXT” worked; “OFFSZTS.TXT”, “AOFFSET.TXT” and “OXFSETS.TXT” didn’t (among others).
I can upload the file correctly via FTP, so I suspect the problem lies somewhere in the AWS interface.
Has anyone else had a problem like this?
Any suggestions on how to debug it?

To eliminate my code, I’ve just tried this with the Digi HTTP File system example on a Connectcore 9215, and get the same problem. So looks as if the problem is within the Net+O/S package

i haven’t seen this before. Please open a support case.

I couldn’t see how to open a support case (we don’t have a support contract).
I’ve traced the problem to a bug in sys/http/file.c in the vicinity of line 700 - the presence of the string “FS” anywhere in the file name causes the name to be truncated. Down to use of strstr() where strcmp() or strncmp() looks to be more appropriate.