I have written a program for Rabbit 2100 in NetBIOS to acquire dynamic IP from DHCP. I have assigned a hostname of my choice to that. When i ping the acquired dynamic ip, i am getting reply. But f I ping with the hostname which i assighed, reply is not getting. Is it like the hostname i have assigned is not registred? If so how can I register it in Rabbit 2100?


I’m having the same problem. How did you assign the hostname? I used the function sethostname(); but it doesn’t seem to work. When I use sethostname, then later I recall it with gethostname, I keep having a blank hostname.

If you already found an answer, I would appreciate a pointer to the solution or to the correct documentation.

Thanks, and good luck


Not all DHCP servers recognize host names. I implemented pretty much the same solution and it’s worked fine on many home routers but not all. It also doesn’t work on the DHCP server running on our Windows 2000 server but it does work on a Linux-based DHCP server.

Try your device on some other DHCP servers and see what happens. That solution should work pretty well.

it works for me with the following:



at least my DHCP server gets the host name correctly.
whether your DNS gets updated, depends on how your DCHP server and your DNS are related.

hope this helps,

Hi there Jon,

Thanks, I will definately give this a try, then post back here to let you know if it worked…



It not work! Help me please…