HOW i can enter XBee S6 to SPI mode?

, ,

I have PCB with ATMega32(with SPI) and XBee S6, but i tired to enter XBee S6 to SPI mode (XBee S6 not answer or answer 000000000000000000 or FFFFFFFFFFFFFF). I read this instruction ( and do all steps to enter XBee S6 to SPI, but he still not answer. What should I do?

I assume you have all the pins hooked up and are holding DOUT low. What is your SPI_nATTN line doing?

See the attached picture.
Her yellow beam - SPI_nattn, blue - nRes, purple - DOUT (PIN2). This image shows that the unit is not moved to the SPI mode as it attempts to answer by UART. I transcribed at the output of UART in binary form following: 011110010101101001010101100001. In this report, there are start and stop bits, and data, In my opinion this is 3 bytes in hex ​​it would be 4F 4B 0D. It’s not like any API frame or AT command. I tried to read the data on the SPI after a narrow peak on the SPI_nattn line all time while SPI_nattn not yet moved to the upper level.

4F 4B 0D this is “OK.” in ASCII codes.

Okay, I understend. This method does not work correctly! I use a different method (manually reassign the pins of the module to SPI using UART):
After I turn power on i choose mode AT commands (send “+++”)
Waiting for an answer “OK.”
Then send following AT commands: ATD21, ATD31, ATD41, ATD96, ATP21. All these commands get a reply “OK.” for each of the commands. Then the serving command to exiting the AT (ATCN) and get the response “OK.”
Immediately after the last response module SPI_nattn pin goes low informing me of the fact that there is data in the buffer SPI. I’m trying to read this data by SPI protocol until the pin goes into the state of the logical 1, but he did not go into this state. SPI still does not work!