How to stop a WR44 from changing GPRS modes?

Hello:

I have a router in Haiti that comes up fine on GPRS, ppp1 comes up, IPSec comes up, the GRE tunnels connect inside the IPSec tunnels and then pings start to get answered from across the link. Within 5 seconds I start getting this in the event log and pings stop:
23:41:24, 03 Jul 2018,Network technology changed to Unknown
23:41:24, 03 Jul 2018,GPRS URC MODE:5,4
23:41:04, 03 Jul 2018,Network technology changed to UMTS
23:40:54, 03 Jul 2018,GPRS URC MODE:5,4
23:40:54, 03 Jul 2018,Network technology changed to Unknown
23:40:45, 03 Jul 2018,GPRS URC MODE:5,4
23:40:24, 03 Jul 2018,Network technology changed to UMTS
23:40:18, 03 Jul 2018,GPRS URC MODE:5,4
23:39:34, 03 Jul 2018,Network technology changed to Unknown
23:39:26, 03 Jul 2018,GPRS URC MODE:5,4
23:39:00, 03 Jul 2018,GPRS URC MODE:5,4
23:38:56, 03 Jul 2018,GPRS URC MODE:5,4
23:38:34, 03 Jul 2018,Network technology changed to UMTS
23:38:28, 03 Jul 2018,GPRS URC MODE:5,4
23:38:24, 03 Jul 2018,Network technology changed to Unknown
23:38:23, 03 Jul 2018,GPRS URC MODE:5,4
23:38:04, 03 Jul 2018,Network technology changed to UMTS
23:37:56, 03 Jul 2018,GPRS URC MODE:5,4
23:37:54, 03 Jul 2018,Network technology changed to Unknown
23:37:46, 03 Jul 2018,GPRS URC MODE:5,4
23:37:24, 03 Jul 2018,Network technology changed to UMTS
23:37:18, 03 Jul 2018,GPRS URC MODE:5,4
23:37:14, 03 Jul 2018,Network technology changed to Unknown
23:37:09, 03 Jul 2018,GPRS URC MODE:5,4
23:36:54, 03 Jul 2018,Network technology changed to UMTS
23:36:44, 03 Jul 2018,GPRS URC MODE:5,4
23:36:44, 03 Jul 2018,Network technology changed to Unknown
23:36:35, 03 Jul 2018,(18) IKE SA Removed. Peer: CNTRL.LAGO,Successful Negotiation
23:36:35, 03 Jul 2018,TUN 0 up

As it bounces from GPRS mode to GPRS mode, the communication link is on-off-on-off.
You can see when it stays on a particular mode, I get 5 or 6 pings until it decides to change and then I lose pings till it settles down.

Is there a way to stop the router from doing this?
I have told it to use 3G/4G in the advanced mobile setup but that had no effect when changing it from auto.

Cheers,
john

Hi

This could be due to poor signal quality it might be worth moving the router or use a higher gain antenna

regards

Hi James:

Thanx for the answer.

We only get this problem with stations that have good signal. This particular site has -57dBm, full three bars.

We don’t see this with other sites.

Note that the two sites we get this at are inside Port au Price (the capitol city), all other sites are in the country side, no issues with the stations in the country side.

Cheers,
John