Iam Getting a constant delay of 6sec after my XBee is connected to mission planner


Iam using XBee SX 868 for communicating between my drone and transmitter.
I Have coordinator connected to laptop and router connected to my drone.
i got the communication 6sec delay.
when i change mode stability to Alt hold to Land i got 6sec delay
When i give Throtle i get 6 sec delay.
Can you say ASAP why it is happening and how to rectify it. Do i need to change any values in Xctu or something else.
Baurd rate 57600.

Thanking you,

I would suggest setting the DL and DH values of both radios to match the SL and Sh of the other. I would also suggest setting the TO command to 0x40.

Hello Sir,
Thanks for the response,
But i have gave all those parameters before itself.
Even after i gave these parameters the delay is showing 6sec.

What is the CM you are using?

Hello sir,
CM is channel mask i kept it default. The CM Iam using is 3EFFFDFF
My BR RF_Data rate is 80kbps[1]
Thank you,

What I would suggest is removing the radios from the device and running a range test. Do you see the same delay from the radios when doing the range test? If not, then it is not the radios causing it.

Hello sir,
As you suggested i had tested the devices. i observed the same delay.

                    Coordinator           Router

BD Baud Rate 57600[6] 57600 [6]
D2 DIO2/AD2 Digital Input [3] Digital Out, Low [4]
D6 DIO6/RTS Disable [0] RTS flow control [1]
D7 DIO7/CTS Digital Input [3] CTS flow control [1]
IR Sample Rate 2000 0
P2 DIO12 Disable [0] Digital Out, Low [4]
IC DIO Change Detect 4 8
TO Transmit Options 40 40

can you suggest me which parameter gives delay.

What is the SP, SM, ST and SO vales set to?

Hello sir,
I apologize for late reply. I never changes these parameters these are the values in both coordinator and router
sp-sleep time 190
sm-sleep mode normal(0)
st-wake time 1F40
so-sleep options 2
My question is is there any parameters that initiate’s delay in the module

I am not seeing anything on the radio that would cause it. I would suggest removing the radios out of the picture and run a wire between the two and see if you have the same delay or not.