incorrectly programmed a 4 mb post into 2 mb digi -S, how can I recover it

I programmed via http this file
Digi Connect 4MB ME POST Firmware 82001229_c.bin
into a connectme -S that I suspect is only 2mb
now it flashes on the green ethernet led 3-3-6 signalling some sort of error in memory size is that possible ?
I tried holding low pin 18 on another digi -S and I obtain the diagnostic screen :

---------------------------- Diagnostic Tests ----------------------------

t) ->TFTP related choices. h) ->Hardware tests.
m) Quick memory test (seconds). M) Long memory test (minutes).
V) Show VPD data. R) Set mfg test result

  1. Erase NVRAM from flash. 2) Erase the BOOTPARM from flash.
  2. Erase the OS from flash. 4) Put TFTP’d OS file into flash.
  3. Run OS. 6) Display hardware strapping.

Enter choice (ESC to exit-Diagnostic Tests)[thmMVR123456] :

but on the digi with I suspect wrong post which should have been :

Digi Connect 2MB ME POST Firmware 82000867_G.bin

I had previously programmed :

Digi Connect 2MB ME EOS Firmware 82000856_F6.bin
and it was rebooting fine but the mix up of 4mb on the 2 mb unit is it possible to recover some way ?


You’ll need to tftp in the correct files:

I cannot access the diagnostic from the serial port, the digi -S just flashes 3-3-6, what does it mean anyway ?

3-3-6 means the unit is failing to initialize. It sounds like you’ll need to RMA the module to get it reflashed.

how would digi reflash it ? do you have any idea ? there must be some hardware way other than holding low pin 18 that brings up the diagnostic dialog, which no longer works with this -S module that since this dialog is a bit intermittent I tried powering it up tens of times to make sure it’s no longer capable of diagnostic dialog.
I have some vague idea that some jtag capability is available on some pins of the serial header on the digi, would you dare to speculate on this possibility.

Actually, when Digi gets the unit in house it will unsolder the flash chip and stick a new flash chip in. The JTAG interface is available on the -C modules for development purposes, not on the -S modules. Contact Digi if you’re in the US or your distributor if you’re outside the US for an RMA.