Installing Etherlite driver to Linux Redhat ES 3

Hi, there is a error message when i try to build the Digi Etherlite rpm for Linux Redhat ES 3. kernel 2.4.21-47.EL

dgrp_net_ops.c:434: incompatible types in assignment
make[1]: *** [dgrp_net_ops.o] Error 1

the rpm file from the installation cd. file: 40002086_K.src.rpm. the same error message appear when i try the rpm i downloaded from file: 40002086_M.src.rpm.

Please help. thanks.

A complete log of the installation will be needed. I recommend contacting Digi Tech. Support to pursue this.

Hi fcs,
I am not positive when it was added to the CD, but normally when you load the CD, and are about to install the driver, it asks for what Distribution you are using.

From the log, it appears its not being selected:

checking if Distro specified… None

Now, it might be that the CD is old, and you don’t have any selection there, but if you do, select your Red Hat distro from the list (I believe it says something like Red Hat AS/ES/WS 3)

Otherwise you can always build the driver by hand, by doing a "rpmbuild --rebuild --define DISTRO=REDHAT_AS_3 .src.rpm


I’m getting the same error on RedHat AS3.0 U4 and U8.

I get this error when trying to compile from either the source .tar.gz or the source rpm using the provided instructions. Was this ever resolved?

attached is the build and installation log. could you forward to Digi Tech Support? thanks a lot.

When installing the driver are you specifying the distribution flag? For example:

Source RPM:

rpmbuild --rebuild --define DISTRO=REDHAT_AS_30 (driver).src.rpm


./configure --with-DISTRO=REDHAT_AS_30