Login Issues in latest firmware.

I’ve been given the task of fixing some issues in our product that began with the last version of firmware on the connectME:
Firmware Version:
(Version 82000856_G_SA204/19/2006)
Boot Version: (release_82000866_C)
POST Version: 1.1.3 (release_82000867_E)

It seems that the authentication has drastically changed. Previously when we disabled user logins from home.htm A login was not required when the default or any other page was opened. We also use the digikey configApp.java to let users change some settings.

With this latest version of firmware, the digi part is forcing a login when user logins have been disabled. We did not change any of the Authentication code. When I do login to the ConfigApp class and change settings through the SecurityView class, java gives a null exception. This is due to the fact that securityView is looking for a “username” field in the simple_password group that does not exist. If I check for null on this node(which it always is) It will say that username/pass is saved, but this is not the case. I also tried adding username as a node like it is done for password, but this does not work either.

Is there any updated applet sourcecode for the latest version of firmware? I tried the tool updated, but I have the latest(several years old).

Any suggestions?

Chris Chelmecki