multiple ethernet connections

Using NetOs 7.4 and have major problems connecting with multiple (actual it’s only 2) PCs to a Unit.

Works fine with 1 single connection, but as soon as I want connect a second PC to the same address (Advanced Web Server) it slows down or even does stop to stop.

Tried HSProperties(xxx) but wasn’t able to add it to the code since it requires a library. when I add the library there are tons of errors cause of multiple defined functions, which are included in the project (by default included).

Did anybody have the same problem and/or an idea how to solve or improve the behavior?

Thanks & Regards


 When you are connecting two PCs to a device running the advanced web server (AWS) are you also debugging or are you just surfing from two different PCs? By debugging I mean are you stepping through the code of a "stub function" or are you simply surfing from two different PCs?

just surfing from 2 pcs. no stepping trough.

Are you running a Digi produced sample application or are you running a web application that you wrote?

I know this is an old case but I wanted to illuminate one issue that was raised. HSProperties is an API tied to the basic web server (BWS) which is obsolete as of NET+OS V7.5 (I know the customer was running V7.4. Further the basic web server and the advanced web server (AWS) can NOT be run within the same system. Thus when the he tried to add the library for BWS that would have included the HSProperties API it is not surprising that he experienced a bunch of linker errors. THis is becuase AWS and BWS do similar operations and do implement some of the same APIs. So some APIs in AWS will conflict with some APIs in BWS, causing the linker errors.