Naming serial port convention RHEL 5


I’m using drivers dgnc-1.3-15.src.rpm (x86_64) under CentOS 5.2 with 2 DIGI NEO PCIe 8 ports cards.

At boot time the serials ports are naming tty_dgnc_0_0 … tty_dgnc_1_7

I needed to manually do a :
service dgnc restart

To have the correct naming convention :
ttyn1a … ttyn2h

How can I fix this problem ?
For information the boot start level for the service is S69dgnc

Thanks in advance,


Can you try the latest driver candidate?

Be sure and remove the existing driver first.


I removed the old driver package. then install :

After rebooting I still have :
/dev/tty_dgnc_0_1 …

And after a manually restarting service:
service dgnc restart
ttyn1b …

I tried to change the start level off the service to S99 but still the same problem.



Sounds like something is failing with UDEV on your system. UDEV controls the device creation and not the driver.

You may want to try running udevmonitor to see if you can catch the problem/error at boot up.


I still have the same problem with CentOS 5.4, 5.6 and 5.7 x86_64.
I tried using the lastest available driver : dgnc-1.3.28.
I also updated the /etc/init.d/dgnc by replacing :
/usr/sbin/dgnc_mknod $n $rest
/sbin/dgnc_mknod $n $rest

and copy all the /usr/sbin/dgnc_* to /sbin but with no success.

Finally I added in /etc/rc.local a restart of the dgnc service :
service dgnc stop
service dgnc start

And now the naming are correct.

But my problem is that I have some services which are using the serial ports and which start before the good naming of serials ports. So they failed.

It seems that I’m not the only one to have this problem.

Do you find any solution for that ?
Did you success to start the dgnc as a service under Red-Hat 5.X with a correct serial port naming ?