Newer Rabbit is not discovered by Rabbit Field Utility

We have two batches of EG2110 Rabbit Link boards which have the Rabbit 2000 microprocessor.

All of our older ones (PCB text: Copyright 2000 Z-World Inc, 175-0251 Rev A) work fine with the Rabbit Field Utility - they are discovered right away.

Our batch of newer (Copyright 2006 Rabbit Semiconductor, 20-175-0251 Rev A) boards cannot be ‘discovered’ by RUF, despite all of the connections being made the same way.

Any suggestions or tips on how to further troubleshoot, or steps we can take to make it communicate?

Our RUF is version 2.45 (works with the older boards but not with the newer boards).

Have you tried the RFU 3.05 that shipped with Dynamic C 9.62?

The problem appeared to be that we were powering our Ethernet switch (which connected our computer to the board) at the same time that we were powering the board.

When the board turns on it polls for an IP. If the switch was not yet fully booted it did not provide the IP. The board only polls once and doesn’t try again if it does not get an IP.

Subsequently if we left the switch powered, and turned on the board, it worked.

1 Like