no network after flashing u-boot ccimx6ulstarter


I’m using the ccimx6ulstarter board. I’m getting stuck with flashing the firmware as described here:

Everything works fine (including updating u-boot via tftp from the host machine). But when I then want to update the kernel and rootfs images as well, u-boot can’t connect to the server (it repeatedly tries to reconnect to the tftp-server but never finishes:

update linux tftp core-image-base-ccimx6ulstarter.boot.ubifs
UBI: attaching mtd1 to ubi0
UBI: scanning is finished
UBI: attached mtd1 (name “mtd=3”, size 14 MiB) to ubi0
UBI: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
UBI: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
UBI: VID header offset: 2048 (aligned 2048), data offset: 4096
UBI: good PEBs: 112, bad PEBs: 0, corrupted PEBs: 0
UBI: user volume: 1, internal volumes: 1, max. volumes count: 128
UBI: max/mean erase counter: 2/1, WL threshold: 4096, image sequence number: 0
UBI: available PEBs: 0, total reserved PEBs: 112, PEBs reserved for bad PEB handling: 40
Using FEC0 device
TFTP from server; our IP address is
Filename ‘core-image-base-ccimx6ulstarter.boot.ubifs’.
Load address: 0x80800000
Loading: T T T T T T T T T T
Retry count exceeded; starting again
Using FEC0 device
TFTP from server; our IP address is
Filename ‘core-image-base-ccimx6ulstarter.boot.ubifs’.
Load address: 0x80800000
Loading: T T T T

u-boot can also not ping my host machine anymore.
I tried this on normal DHCP-network as well as on a manually setup point to point connection from the board to the host machine, always using the Ethernet interface.

Furthermore, I set up everything and built the image according to the DIGI home page here:

and here:

I did not customize the root file system, just wanted to go through the process of building and flashing one time.

As a workaround I put the image files onto an SD-card and then ran “run install_linux_fw_sd” in u-boot. It seems to have installed u-boot and Linux properly, everything starts as usual.

I would be very thankful for any help! Please let me know in case I need to add some information.


are you using virtual machine? bridged mode networking ? is firewall enabled?

>u-boot can also not ping my host machine anymore.
This worked before? what has changed? new u-boot?

Hello, thank you for the answer!

Pinging the host machine from u-boot worked fine before.
Only u-boot has changed at that state where the problem occurs. With Firmware I meant Kernel + rootfs, sorry about that.

I’m using native Ubuntu 16.04 on the host machine. Firewall shouldn’t be enabled (I’ll check that tomorrow). I set up the network on the host like this: sudo ip ad add dev eth0.
In u-boot, I set the corresponding env variables to and


Please try flashing precompiled u-boot via SD card as described in getting started guide and see if you get network connection back

Yes, I can flash the precompiled u-boot and yes, network connection works again. I’m having the problem only with the (own-)compiled u-boot.

Then there must be something wrong about your build. Are you building “minimal” ? Are you changing anything?

No, I built the normal core-image-base, following the DIGI tutorial, described in my original post.

Didn’t know that there’s a “minimal” image available for the ccimx6ulstarter. Otherwise I would have liked to use it.


no, base is fine
Normaly you should use core-image-base on dey-2.0.r4. You could extend core-image-minimal to work in DEY in the same way as it is done for core-image-base:
did you make any changes to the source? Yuo have starter board, right? Can you please attach the u-boot boot log

The U-Boot boot log:

U-Boot dub-2015.04-r4.5+ga714275 (Nov 24 2016 - 13:24:30)

CPU: Freescale i.MX6UL rev1.1 528 MHz (running at 396 MHz)
CPU: Industrial temperature grade (-40C to 105C) at 35C
Reset cause: POR
I2C: ready
DRAM: 256 MiB
PMIC: PFUZE300 DEV_ID=0x30 REV_ID=0x11
NAND: 256 MiB
In: serial
Out: serial
Err: serial
ConnectCore 6UL SOM variant 0x02: Industrial Ultralite 528MHz, 256MB NAND, 256MB DDR3, -40/+85C, Wireless, Bluetooth
Board: ConnectCore 6UL StarterBoard, version 1, ID 129
Net: FEC0
Hit any key to stop autoboot: 0


Right, I posted the u-boot log above.
I did not make any changes to the source and yes, I have the starter board.

Please take a look at the workaround detailed here:|Known%2520issues|_____2

You can tell if your Starter Board is version 2 by looking for the number 30015102-02 on the top-layer screen printing near the CONSOLE/POWER connector.
If your Starter Board is version 2 but U-Boot reports it as version 1, Ethernet does not work in U-Boot.
Download the latest released images of Digi Embedded Yocto and follow the procedure to program the firmware into the device. See Step 3: Program the Yocto firmware. The latest U-Boot version reports the Starter Board version correctly and Ethernet works normally.
To fix the issue in source code, sync your installation with the head of the release branch as follows:
cd /usr/local/dey-2.0/
repo init -u -b jethro
repo sync -j4 --no-repo-verify

Thanks, this solved my problem, flashing via tftp no problem now anymore.